summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-07-02 14:25:39 -0400
committeracxz2020-07-02 14:25:39 -0400
commitb5ea268cef5c2eb6dbe463780be5b563506d6fb3 (patch)
tree3a9007442e0c452c48fbff414fc385f0d518579c
downloadaur-b5ea268cef5c2eb6dbe463780be5b563506d6fb3.tar.gz
create orocos-kdl-git package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59a016ae65b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = orocos-kdl-git
+ pkgdesc = The Kinematics and Dynamics Library is a framework for modelling and computation of kinematic chains
+ pkgver = r931.546d04d
+ pkgrel = 1
+ url = http://www.orocos.org/kdl
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = eigen
+ source = git+https://github.com/orocos/orocos_kinematics_dynamics
+ sha256sums = SKIP
+
+pkgname = orocos-kdl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64cc1840caf0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributor: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=orocos-kdl-git
+pkgver=r931.546d04d
+pkgrel=1
+pkgdesc="The Kinematics and Dynamics Library is a framework for modelling and computation of kinematic chains"
+arch=('i686' 'x86_64')
+url="http://www.orocos.org/kdl"
+license=('GPL')
+depends=(eigen)
+makedepends=(cmake)
+source=(git+https://github.com/orocos/orocos_kinematics_dynamics)
+sha256sums=('SKIP')
+
+_dir=orocos_kinematics_dynamics
+_pkgname=orocos_kdl
+
+pkgver() {
+ cd "${srcdir}/${_dir}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_dir}/${_pkgname}"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${srcdir}/${_dir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}