summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2021-01-12 11:09:13 -0500
committeracxz2021-01-12 11:09:13 -0500
commiteb9cc3d84e9f01a8344d34d09850009b832299cd (patch)
tree203f5524cb1989212fb1c52f9d07b86376c2dbe1
parente77809f45cf313eca4ebc9963e4b9127800902b2 (diff)
downloadaur-eb9cc3d84e9f01a8344d34d09850009b832299cd.tar.gz
ensure py3 is used
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c6d4addae96..c0bc6fb7145e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = orocos-kdl-python
pkgdesc = The Kinematics and Dynamics Library is a framework for modelling and computation of kinematic chains (Python binding)
pkgver = 1.4.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.orocos.org/kdl
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 46f08f74b543..3b8f61a36108 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=orocos-kdl-python
_dir=orocos_kinematics_dynamics
_pkgname=python_orocos_kdl
pkgver=1.4.0
-pkgrel=3
+pkgrel=4
pkgdesc="The Kinematics and Dynamics Library is a framework for modelling and computation of kinematic chains (Python binding)"
arch=('i686' 'x86_64')
url="https://www.orocos.org/kdl"
@@ -26,7 +26,9 @@ prepare() {
build() {
cd "${srcdir}/${_dir}-${pkgver}/${_pkgname}"
mkdir -p build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_VERSION=3 \
+ ..
make
}