summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsvenschneider2013-05-25 10:54:01 +0200
committersvenschneider2013-05-25 11:02:06 +0200
commit241cda1b2f84115fdcdbf6e1984a87895729c4bb (patch)
treef8c8ade8704e209f538587587f7010c5e1e19859
parent98a73bc8177a612a0157c87740a6ad798ac13578 (diff)
downloadaur-241cda1b2f84115fdcdbf6e1984a87895729c4bb.tar.gz
orocos-rtt: include patch for boost problem
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
-rw-r--r--boost.diff20
3 files changed, 37 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1dfbf86a97e..c59bbe4e430c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,10 +10,15 @@ pkgbase = orocos-rtt
makedepends = cmake
depends = boost-libs
source = http://people.mech.kuleuven.be/~orocos/pub/stable/toolchain/v2.6.0/orocos-toolchain-2.6.0-src.tar.bz2
+ source = boost.diff
md5sums = ac68f90da0d7c4595e5d78687d68ab2f
+ md5sums = e4fa9508a90d20a5437ceed5ec8b72ff
sha256sums = d98adaf4975ffef6b79b7d31f16c488014e347afbc5549910f209db4a9f469fd
+ sha256sums = 6f242c19983e556505206cda3406060c3d93652d21d8fabf537dbcbd2d7e7b0b
sha384sums = 6fc673dd6a5f034b21f87b2171f6303077a5759cdcc7c9dd745e44b1a51a7a5a4028455c6588b24556d2d3907dd5b372
+ sha384sums = aa629cf52c075f6a84c1ca33c7b75cb947d65ac6254e85173bc74a7a44c18743a6780d181b3a6b79aa823d2215177e63
sha512sums = 7d30ac8bb751c489302cb15c8a613345aabb2023c935c04f371bb35b52faabd9563e20da384fbe409a7f4533c133eea983484800680d22737be95b37653a6be9
+ sha512sums = 31b88512783b07218cbda58a292f98fae190610ea4e8cc03472d4c81656b299015ecc2c256ecd70b70617046f2aad17bf5a5fcb3072f608840453592eda29410
pkgname = orocos-rtt
diff --git a/PKGBUILD b/PKGBUILD
index 27dfa96320b5..72d9b93bd8e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,16 +11,23 @@ license=('GPL')
groups=('orocos-toolchain')
depends=('boost-libs')
makedepends=('cmake')
-source=(http://people.mech.kuleuven.be/~orocos/pub/stable/toolchain/v${pkgver}/${_pkgname}-${pkgver}-src.tar.bz2)
-md5sums=('ac68f90da0d7c4595e5d78687d68ab2f')
-sha256sums=('d98adaf4975ffef6b79b7d31f16c488014e347afbc5549910f209db4a9f469fd')
-sha384sums=('6fc673dd6a5f034b21f87b2171f6303077a5759cdcc7c9dd745e44b1a51a7a5a4028455c6588b24556d2d3907dd5b372')
-sha512sums=('7d30ac8bb751c489302cb15c8a613345aabb2023c935c04f371bb35b52faabd9563e20da384fbe409a7f4533c133eea983484800680d22737be95b37653a6be9')
+source=(http://people.mech.kuleuven.be/~orocos/pub/stable/toolchain/v${pkgver}/${_pkgname}-${pkgver}-src.tar.bz2
+ boost.diff)
+md5sums=('ac68f90da0d7c4595e5d78687d68ab2f'
+ 'e4fa9508a90d20a5437ceed5ec8b72ff')
+sha256sums=('d98adaf4975ffef6b79b7d31f16c488014e347afbc5549910f209db4a9f469fd'
+ '6f242c19983e556505206cda3406060c3d93652d21d8fabf537dbcbd2d7e7b0b')
+sha384sums=('6fc673dd6a5f034b21f87b2171f6303077a5759cdcc7c9dd745e44b1a51a7a5a4028455c6588b24556d2d3907dd5b372'
+ 'aa629cf52c075f6a84c1ca33c7b75cb947d65ac6254e85173bc74a7a44c18743a6780d181b3a6b79aa823d2215177e63')
+sha512sums=('7d30ac8bb751c489302cb15c8a613345aabb2023c935c04f371bb35b52faabd9563e20da384fbe409a7f4533c133eea983484800680d22737be95b37653a6be9'
+ '31b88512783b07218cbda58a292f98fae190610ea4e8cc03472d4c81656b299015ecc2c256ecd70b70617046f2aad17bf5a5fcb3072f608840453592eda29410')
build() {
# build rtt
cd "${srcdir}/${_pkgname}-${pkgver}/rtt"
+ patch -p1 < "${srcdir}/boost.diff"
+
# update the cmake configuration file so that it finds the RTT
sed 's/set(OROCOS-RTT_FOUND ${OROCOS-RTT_IMPORT_FILE})/set(OROCOS-RTT_FOUND TRUE)/g' -i orocos-rtt-config.cmake
diff --git a/boost.diff b/boost.diff
new file mode 100644
index 000000000000..fb591705aaee
--- /dev/null
+++ b/boost.diff
@@ -0,0 +1,20 @@
+--- a/rtt/Service.hpp
++++ b/rtt/Service.hpp
+@@ -58,7 +58,7 @@
+ #include <boost/type_traits/function_traits.hpp>
+ #include <boost/function_types/components.hpp>
+ #include <boost/enable_shared_from_this.hpp>
+-#if BOOST_VERSION >= 104000
++#if BOOST_VERSION >= 104000 && BOOST_VERSION <= 105030
+ #include <boost/smart_ptr/enable_shared_from_this2.hpp>
+ #endif
+
+@@ -82,7 +82,7 @@
+ : public OperationInterface,
+ public ConfigurationInterface,
+ public DataFlowInterface,
+-#if BOOST_VERSION >= 104000
++#if BOOST_VERSION >= 104000 && BOOST_VERSION <= 105030
+ public boost::enable_shared_from_this2<Service>
+ #else
+ public boost::enable_shared_from_this<Service> \ No newline at end of file