summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2019-10-20 19:27:47 +0200
committerWilliam Gathoye2019-10-20 21:16:54 +0200
commita497a672d2efe880d28355d8ccb47e5a7ee54284 (patch)
tree20250065cd22e7a266733b99c86ab07d3fa1a30d
parente31400c9eb7add1ecbaff8d11171aad769a02833 (diff)
downloadaur-a497a672d2efe880d28355d8ccb47e5a7ee54284.tar.gz
Upgrade to 1.5.8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD56
2 files changed, 36 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c70b71d5644..e070f8a6cf72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = orthanc
pkgdesc = Open-source, lightweight DICOM server.
- pkgver = 1.3.2
+ pkgver = 1.5.8
pkgrel = 1
url = http://orthanc-server.com/
arch = x86_64
@@ -21,8 +21,8 @@ pkgbase = orthanc
depends = pugixml
depends = sqlite
depends = util-linux
- source = https://www.orthanc-server.com/downloads/get.php?path=/orthanc/Orthanc-1.3.2.tar.gz
- sha256sums = 2357210fb6d7d8d99d5b67c3136abd7e7ec23a92f0946eeb2661aad7e6dcaaf3
+ source = https://www.orthanc-server.com/downloads/get.php?path=/orthanc/Orthanc-1.5.8.tar.gz
+ sha512sums = 2357210fb6d7d8d99d5b67c3136abd7e7ec23a92f0946eeb2661aad7e6dcaaf3
pkgname = orthanc
diff --git a/PKGBUILD b/PKGBUILD
index 43654cb7e73f..b65b2eb3b2ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,50 @@
-# Maintainer: Michal Malek <michalm@fastmail.fm>
+# Maintainer: William Gathoye <william + aur at gathoye dot be>
+# Contributor: Michal Malek <michalm@fastmail.fm>
# Contributor: Sharif Olorin <sio@tesser.org>
pkgname=orthanc
-pkgver=1.3.2
+pkgver=1.5.8
pkgrel=1
-pkgdesc="Open-source, lightweight DICOM server."
-arch=("x86_64" "i686")
-url="http://orthanc-server.com/"
-license=("custom:GPL3WithOpenSSLException")
-source=("https://www.orthanc-server.com/downloads/get.php?path=/orthanc/Orthanc-${pkgver}.tar.gz")
-sha256sums=('2357210fb6d7d8d99d5b67c3136abd7e7ec23a92f0946eeb2661aad7e6dcaaf3')
-depends=("boost" "curl" "dcmtk" "jsoncpp" "libjpeg-turbo" "libpng" "openssl" "pugixml" "sqlite" "util-linux")
-makedepends=("cmake" "doxygen" "gtest" "make" "python")
+pkgdesc='Open-source, lightweight DICOM server.'
+arch=('x86_64' 'i686')
+url='http://orthanc-server.com/'
+license=('GPL3')
+
+depends=(
+ 'boost-libs' 'curl' 'dcmtk' 'jsoncpp' 'libjpeg-turbo' 'lua' 'pugixml' 'sqlite'
+)
+makedepends=(
+ 'boost' 'cmake' 'doxygen' 'gtest' 'make' 'python' 'unzip'
+)
+source=(
+ "https://www.orthanc-server.com/downloads/get.php?path=/orthanc/Orthanc-${pkgver}.tar.gz"
+)
+sha512sums=(
+ '9610526cff59e2061e16728d7ce78a80dd8803371ac80be561349476bac011ad2200b1e144df13b4e94174a90591ed8a1a0c258c98122f934ce4e70b320568e5'
+)
build() {
cmake \
- -H${srcdir}/Orthanc-${pkgver} \
- -B${srcdir}/build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
-DALLOW_DOWNLOADS=ON \
- -DUSE_SYSTEM_LUA=OFF \
- -DUSE_SYSTEM_MONGOOSE=OFF
- cmake --build ${srcdir}/build
- cmake --build ${srcdir}/build --target doc
+ -DUSE_SYSTEM_CIVETWEB=OFF \
+ -DBoost_NO_BOOST_CMAKE=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -H"${srcdir}"/Orthanc-"${pkgver}" \
+ -B"${srcdir}"/build
+
+ cmake --build "${srcdir}"/build
+ cmake --build "${srcdir}"/build --target doc
}
check() {
- cd ${srcdir}/build
+ cd "${srcdir}"/build
./UnitTests
}
package() {
- cmake --build ${srcdir}/build --target install -- DESTDIR=${pkgdir}
- install -m 444 -D ${srcdir}/Orthanc-${pkgver}/COPYING ${pkgdir}/usr/share/licenses/${pkgname}
+ cmake --build "${srcdir}"/build --target install -- DESTDIR="${pkgdir}"
mkdir -p ${pkgdir}/usr/bin
- mv ${pkgdir}/usr/sbin/* ${pkgdir}/usr/bin
- rmdir ${pkgdir}/usr/sbin
+ mv "${pkgdir}"/usr/sbin/* ${pkgdir}/usr/bin
+ rmdir "${pkgdir}"/usr/sbin
}