summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:39:32 +0200
committerSanskritFritz2015-06-14 00:39:32 +0200
commit0bc07aac549b6f42ddd62d26c13ad750c4796eaa (patch)
tree9ae652a581433309bcae2167c25a3037c9687115
downloadaur-0bc07aac549b6f42ddd62d26c13ad750c4796eaa.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD36
-rwxr-xr-xorthorobot.desktop13
-rwxr-xr-xorthorobot.sh3
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3770f9333bea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = orthorobot
+ pkgdesc = Perspective based puzzle game, where you flatten the view to move across gaps
+ pkgver = 1.0
+ pkgrel = 4
+ url = http://stabyourself.net/orthorobot/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = love07
+ source = http://stabyourself.net/dl.php?file=orthorobot/orthorobot-linux.zip
+ source = https://bitbucket.org/rude/love/raw/0.7.0/platform/unix/app.svg
+ source = orthorobot.sh
+ source = orthorobot.desktop
+ md5sums = 3ba42cd5058660d6750cdbcb3cf477df
+ md5sums = a1e19f91420cc519a683af360f5b1120
+ md5sums = 4b43b2f28fe7af330b78152131fc8772
+ md5sums = 4d5757d30b2b07c9062d3fe02ce65a57
+
+pkgname = orthorobot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e85058020b61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: archtux <antonio dot arias99999 at gmail dot com>
+
+pkgname=orthorobot
+pkgver=1.0
+pkgrel=4
+pkgdesc='Perspective based puzzle game, where you flatten the view to move across gaps'
+arch=('i686' 'x86_64')
+url="http://stabyourself.net/orthorobot/"
+license=('GPL')
+depends=('love07')
+makedepends=('unzip')
+_gamepkg=${pkgname}-linux.zip
+source=(http://stabyourself.net/dl.php?file=orthorobot/orthorobot-linux.zip
+ https://bitbucket.org/rude/love/raw/0.7.0/platform/unix/app.svg
+ $pkgname.sh
+ $pkgname.desktop)
+md5sums=('3ba42cd5058660d6750cdbcb3cf477df'
+ 'a1e19f91420cc519a683af360f5b1120'
+ '4b43b2f28fe7af330b78152131fc8772'
+ '4d5757d30b2b07c9062d3fe02ce65a57')
+
+package() {
+ cd $srcdir
+
+ unzip -o $srcdir/$_gamepkg -d $srcdir/$pkgname
+
+ # Start file
+ install -Dm755 $pkgname.sh $pkgdir/usr/bin/$pkgname
+
+ # Executable
+ install -Dm644 $pkgname/Ortho\ Robot.love $pkgdir/usr/share/games/$pkgname/$pkgname.love
+
+ # Desktop icon
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 app.svg $pkgdir/usr/share/pixmaps/$pkgname.svg
+} \ No newline at end of file
diff --git a/orthorobot.desktop b/orthorobot.desktop
new file mode 100755
index 000000000000..2273ea473251
--- /dev/null
+++ b/orthorobot.desktop
@@ -0,0 +1,13 @@
+
+[Desktop Entry]
+Version=1.0
+Type=Application
+Icon=/usr/share/pixmaps/orthorobot.svg
+Exec=orthorobot
+Terminal=false
+StartupNotify=false
+Name=Orthorobot
+GenericName=Arcade Game
+Comment=Perspective based puzzle game, where you flatten the view to move across gaps
+Categories=Game;ArcadeGame;
+Name[en_GB]=orthorobot
diff --git a/orthorobot.sh b/orthorobot.sh
new file mode 100755
index 000000000000..576cb18bee78
--- /dev/null
+++ b/orthorobot.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/games/orthorobot
+love07 ./orthorobot.love