summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-10-14 14:03:47 -0400
committerGuillaume Horel2017-10-14 14:03:47 -0400
commit3f13ef21a6c1419b8b5e11e6a069c815aa24c909 (patch)
treeeeb480ebcb0c79e7bef2e85fd0913a8bcf955a74
parent677016b989301bff8ea3fbd218929aae082a118f (diff)
downloadaur-3f13ef21a6c1419b8b5e11e6a069c815aa24c909.tar.gz
Version bump
switch to cmake
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD50
2 files changed, 33 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 877df5dd9577..90c0f31f4c6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = ortp-git
- pkgdesc = oRTP is a LGPL licensed C library implementing the RTP protocol (rfc3550)
- pkgver = 0.22.0.r276.gfbe5a32
+ pkgdesc = A Real-time Transport Protocol (RTP) library
+ pkgver = 1.0.2.r11.g5f8fcdd
pkgrel = 1
- url = http://www.linphone.org/
+ url = https://github.com/BelledonneCommunications/ortp
arch = i686
arch = x86_64
- license = LGPL2
- depends = openssl
- depends = libsrtp
+ license = GPL3
+ makedepends = cmake
+ depends = bctoolbox-git
provides = ortp
conflicts = ortp
- options = !libtool
- source = git://git.linphone.org/ortp.git
+ source = git+https://github.com/BelledonneCommunications/ortp.git
sha256sums = SKIP
pkgname = ortp-git
diff --git a/PKGBUILD b/PKGBUILD
index 319c347c18b7..326037d1ca0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
+# $Id$
+# Contributor: Guillaume Horel <guillaume.horel@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Jaroslaw Swierczynski <swiergot@aur.archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
pkgname=ortp-git
-_basename="ortp"
-pkgver=0.22.0.r276.gfbe5a32
+_pkgname=ortp
+pkgver=1.0.2.r11.g5f8fcdd
pkgrel=1
-pkgdesc="oRTP is a LGPL licensed C library implementing the RTP protocol (rfc3550)"
-arch=(i686 x86_64)
-url="http://www.linphone.org/"
-license=('LGPL2')
-options=(!libtool)
-depends=('openssl' 'libsrtp')
-source=("git://git.linphone.org/${_basename}.git")
+pkgdesc="A Real-time Transport Protocol (RTP) library"
+arch=('i686' 'x86_64')
+url="https://github.com/BelledonneCommunications/ortp"
+license=('GPL3')
+conflicts=('ortp')
+provides=('ortp')
+depends=('bctoolbox-git')
+makedepends=('cmake')
+source=("git+https://github.com/BelledonneCommunications/ortp.git")
sha256sums=('SKIP')
-provides=("${_basename}")
-conflicts=("${_basename}")
-
-prepare() {
- cd "$_basename"
- ./autogen.sh
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}
build() {
- cd "$_basename"
- ./configure --prefix=/usr
+ cd ${_pkgname}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DENABLE_STATIC="NO" .
make
}
package() {
- cd "$_basename"
- make DESTDIR=$pkgdir install
-}
-
-pkgver() {
- cd "$_basename"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
}