summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 10:42:06 -0700
committerMark Wagie2024-01-21 10:42:06 -0700
commit6a6f1dce9f169389fe608feedc9778867c7571b0 (patch)
treeae178f3d2f15e2452a1a2b3ef6c14955bf0fd541
parent505d792a2766d498894dcce802b0da4ac8c8253e (diff)
downloadaur-oryx-kb-leds.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfcd6524868d..6678da9cff31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = oryx-kb-leds
url = https://github.com/davemcphee/oryx-kb-leds
install = oryx-kb-leds.install
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 0bcb2a95541f..f57d52950d93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=oryx-kb-leds
pkgver=1.1
pkgrel=4
pkgdesc="Control your Oryx Pro's Keyboard LEDs"
arch=('x86_64')
url="https://github.com/davemcphee/oryx-kb-leds"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('python-colour' 'python-psutil' 'python-pyaml' 'system76-dkms')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
install="$pkgname.install"
@@ -21,6 +21,6 @@ package() {
cd "$pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 systemd/oryxkbleds.service -t "$pkgdir/usr/lib/systemd/system"
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 systemd/oryxkbleds.service -t "$pkgdir/usr/lib/systemd/system/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}