summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-12-09 13:01:58 -0700
committerMark Wagie2020-12-09 13:01:58 -0700
commitec383cbce6b97ee68f97818b829fe7a624be5cb5 (patch)
treea72a83d20482a3ecaefd9920ba50116be740a896
downloadaur-ec383cbce6b97ee68f97818b829fe7a624be5cb5.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD27
-rw-r--r--oryx-kb-leds.install14
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75915bc9a9b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = oryx-kb-leds
+ pkgdesc = Control your Oryx Pro's Keyboard LEDs
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/davemcphee/oryx-kb-leds
+ install = oryx-kb-leds.install
+ arch = x86_64
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-colour
+ depends = python-psutil
+ depends = python-pyaml
+ source = oryx-kb-leds-1.1.tar.gz::https://github.com/davemcphee/oryx-kb-leds/archive/1.1.tar.gz
+ sha256sums = d1ebeaf7464147beb3dba36e629b0e0afe5e31c6243cef298998eb2afe240a16
+
+pkgname = oryx-kb-leds
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..55cb6a1e1b00
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!oryx-kb-leds.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01c29f2b34c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=oryx-kb-leds
+pkgver=1.1
+pkgrel=1
+pkgdesc="Control your Oryx Pro's Keyboard LEDs"
+arch=('x86_64')
+url="https://github.com/davemcphee/oryx-kb-leds"
+license=('GPL3')
+depends=('python-colour' 'python-psutil' 'python-pyaml')
+makedepends=('python-setuptools')
+install="$pkgname.install"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('d1ebeaf7464147beb3dba36e629b0e0afe5e31c6243cef298998eb2afe240a16')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 systemd/oryxkbleds.service -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+}
diff --git a/oryx-kb-leds.install b/oryx-kb-leds.install
new file mode 100644
index 000000000000..b5d6099e2d94
--- /dev/null
+++ b/oryx-kb-leds.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo ""
+ echo "Enable the service:"
+ echo "systemctl enable --now oryxkbleds.service"
+ echo ""
+}
+
+post_upgrade() {
+ echo ""
+ echo "Restart the service:"
+ echo "systemctl daemon-reload"
+ echo "systemctl restart oryxkbleds.service"
+ echo ""
+}