summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbemxio2023-12-07 01:11:14 +0100
committerbemxio2023-12-07 01:11:14 +0100
commit70d6205c64be38411c8bb2586b85b4c0afebd62a (patch)
tree29206bc5cd579bf15e850f1f0045bc2d61f3c9c0
downloadaur-70d6205c64be38411c8bb2586b85b4c0afebd62a.tar.gz
create the first version of the package
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD61
-rwxr-xr-xosaka-simulator22
-rw-r--r--tsu_han.cfg22
5 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2523e710e4d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = osaka-simulator
+ pkgdesc = A fanmade interactive Osaka simulator from hirahira.net for PC
+ pkgver = Aug_2003
+ pkgrel = 1
+ url = https://azumanga.fandom.com/wiki/Ayumu_Kasuga%27s_Mail_Order_Life
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = unzip
+ makedepends = gendesk
+ makedepends = icoutils
+ depends = wine
+ depends = winetricks
+ provides = osaka-simulator
+ source = local://Osaka Simulator FINAL (standalone).zip
+ source = osaka-simulator
+ source = tsu_han.cfg
+ md5sums = 69c5e729bd4acc28320afbcc863b454a
+ md5sums = 8af04a78b75b73656908f722d6cbce19
+ md5sums = 7b644ee8fdf4d1b8213115bef3a1b90c
+
+pkgname = osaka-simulator
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e84d3bcccc2e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+# Source and package folders
+src/
+pkg/
+
+# Archive files
+*.zip
+*.tar.gz
+*.tar.xz
+
+# Package files
+*.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9639d174121
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: bemxio <bemxiov@protonmail.com>
+
+pkgname="osaka-simulator"
+pkgdesc="A fanmade interactive Osaka simulator from hirahira.net for PC"
+
+pkgver=Aug_2003
+pkgrel=1
+
+arch=(i686 x86_64)
+
+url="https://azumanga.fandom.com/wiki/Ayumu_Kasuga%27s_Mail_Order_Life"
+license=("unknown")
+
+depends=(wine winetricks)
+makedepends=(unzip gendesk icoutils)
+
+provides=(osaka-simulator)
+
+source=("local://Osaka Simulator FINAL (standalone).zip" "osaka-simulator" "tsu_han.cfg")
+md5sums=("69c5e729bd4acc28320afbcc863b454a" "8af04a78b75b73656908f722d6cbce19" "7b644ee8fdf4d1b8213115bef3a1b90c")
+
+prepare() {
+ # extract the icon out of the executable
+ wrestool -x -n 128 "Osaka Simulator FINAL/tsu_han.exe" -o OsakaSimulator.ico
+
+ # get the highest quality PNG from the icon file
+ icotool -x OsakaSimulator.ico -i 3 -o OsakaSimulator.png
+
+ # generate a .desktop file
+ gendesk -f -n \
+ --pkgname "Ayumu Kasuga's Mail Order Life" \
+ --pkgdesc "${pkgdesc}" \
+ --exec osaka-simulator \
+ --icon OsakaSimulator.png \
+ --categories "Game;Simulation"
+}
+
+package() {
+ # make the required directory
+ mkdir -p "${pkgdir}/opt/osaka-simulator"
+
+ # copy the game's files
+ cp -r "${srcdir}/Osaka Simulator FINAL"/* "${pkgdir}/opt/osaka-simulator"
+
+ # delete the bundled-in save file and configuration file
+ rm -f "${pkgdir}/opt/osaka-simulator/tsu_han.dat"
+ rm -f "${pkgdir}/opt/osaka-simulator/tsu_han.cfg"
+
+ # copy the package's configuration file
+ install -Dm644 "${srcdir}/tsu_han.cfg" "${pkgdir}/opt/osaka-simulator/tsu_han.cfg"
+
+ # set the ownership of the game's directory to root:games
+ chown -R root:games "${pkgdir}/opt/osaka-simulator"
+
+ # copy the executable script
+ install -Dm755 "${srcdir}/osaka-simulator" "${pkgdir}/usr/bin/osaka-simulator"
+
+ # copy the extracted icon and the generated .desktop file
+ install -Dm644 OsakaSimulator.png "${pkgdir}/usr/share/pixmaps/OsakaSimulator.png"
+ install -Dm644 "Ayumu Kasuga's Mail Order Life.desktop" "${pkgdir}/usr/share/applications/OsakaSimulator.desktop"
+} \ No newline at end of file
diff --git a/osaka-simulator b/osaka-simulator
new file mode 100755
index 000000000000..fc7436698479
--- /dev/null
+++ b/osaka-simulator
@@ -0,0 +1,22 @@
+#!/bin/bash
+
+# set environment variables for wine
+export WINEARCH=win32 WINEPREFIX="$HOME/.osaka-simulator"
+
+# check if the game's user directory has been initialized
+if [ ! -d "$HOME/.osaka-simulator" ]; then
+ # create the directory for the wine prefix
+ mkdir -p "$HOME/.osaka-simulator" || exit 1
+
+ # initiaize the wine prefix
+ wineboot -i || exit 1
+
+ # install the required dependencies using winetricks
+ winetricks -q dmime dmsynth dmusic dsound dswave dx8vb || exit 1
+fi
+
+# move into the game's directory
+cd /opt/osaka-simulator || exit 1
+
+# run the game
+WINEDEBUG=-all wine /opt/osaka-simulator/tsu_han.exe "$@" \ No newline at end of file
diff --git a/tsu_han.cfg b/tsu_han.cfg
new file mode 100644
index 000000000000..50d322a5d150
--- /dev/null
+++ b/tsu_han.cfg
@@ -0,0 +1,22 @@
+// ShaderMode(0:ハードウェアが利用可能であれば利用する 1:常にソフトウェア実行)
+0
+// WindowConfig(0:640x640 1:800x800 2:1200x1200)
+1
+// WindowMode(0:Window&Clip 1:Window 2:Fullscreen)
+1
+// TopmostMode(0:Not topmost 1:Topmost)
+0
+// FixMode(0:Not fix 1:Fix)
+0
+// InitX
+0
+// InitY
+0
+// SoundMode(0:Off 1:On)
+1
+// CameraMode(0:Manual 1:Auto)
+1
+// HirahiraMode(0:Off 1:On)
+1
+// ClearMode(0:Not clear data 1:Clear data)
+0