summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShivam Mistry2017-04-12 23:11:39 +0100
committerShivam Mistry2017-04-12 23:27:39 +0100
commit851d75785dc08c1534ae9eea09928168d2ec185f (patch)
tree0c024231f4d246793b7fc99470ffe92856d03be5
parent8db946928dbda6c7b0b4d932e51d22bef2db8c7c (diff)
downloadaur-851d75785dc08c1534ae9eea09928168d2ec185f.tar.gz
Update to version 1.0.4
-rw-r--r--PKGBUILD10
-rwxr-xr-xosbuddy3
-rw-r--r--osbuddy.install2
3 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecd6e476db14..921dcc0dd4ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Shivam Mistry <shivam@automaton.uk>
pkgname=osbuddy
-pkgver=1.0.3
-pkgrel=2
+pkgver=1.0.4
+pkgrel=1
pkgdesc="Launcher for the OldSchool RuneScape toolkit"
arch=('any')
url="https://rsbuddy.com/osbuddy"
license=('custom')
-depends=('java-runtime')
+depends=('java-runtime=8')
optdepends=()
options=()
install='osbuddy.install'
source=(http://cdn.rsbuddy.com/live/f/loader/OSBuddy.jar osbuddy osbuddy.desktop osbuddy.png osbuddy.install LICENSE)
noextract=("OSBuddy.jar")
md5sums=('61ed8172507131e64f77fcd5c8e1e880'
- 'ef94b41052c080e214edac34c673c197'
+ 'fe21c768c3e41ef6e74773082d1d94f0'
'96ee5f2ec6e827516b9e557c08729cde'
'5edc1b9aef7d753402180df474bb391f'
- '72577c1b6eca8aebfeee9ca14db7a8f6'
+ 'f695898684e85bdbacc2b5be1bed9180'
'ef50529b59e1b789bae48bea7e0e7bf2')
package() {
cd "$srcdir"
diff --git a/osbuddy b/osbuddy
index 54c8690b524b..61cba5ed774a 100755
--- a/osbuddy
+++ b/osbuddy
@@ -1,3 +1,4 @@
#!/usr/bin/env sh
-_JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=on' exec java -Dnofork=true -Xmx512M $OSBUDDY_VMARGS -jar /usr/share/osbuddy/OSBuddy.jar $@
+_JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=lcd' exec java -Dnofork=true -Xmx512M -Dswing.aatext=true $OSBUDDY_VMARGS -jar /usr/share/osbuddy/OSBuddy.jar $@
+
diff --git a/osbuddy.install b/osbuddy.install
index 1e6f3512f6f4..1c21c487793a 100644
--- a/osbuddy.install
+++ b/osbuddy.install
@@ -2,7 +2,7 @@
post_install() {
echo "NOTE"
echo ">>> You will need to have an account at http://rsbuddy.com to use OSBuddy"
- echo ">>> You can also upgrade to OSBuddy Pro at the same URL for a price of 2GBP a month."
+ echo ">>> You can also upgrade to OSBuddy Pro at the same URL for a price of 2.50GBP a month."
echo ">>> OSBuddy will store and upgrade itself in ~/.osbuddy/"
}