summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rheinsberg2020-03-02 15:12:18 +0100
committerDavid Rheinsberg2020-03-02 15:12:18 +0100
commitd3243e0396ff71eb3c9d6178a6ad0baf3954cf98 (patch)
treed4e134833a30c36d502562b742f687873eae1e02
downloadaur-d3243e0396ff71eb3c9d6178a6ad0baf3954cf98.tar.gz
osbuild: initialize new package
This initializes the new `osbuild` package. It is an Archlinux package for the osbuild project: - https://www.osbuild.org - https://github.com/osbuild/osbuild Signed-off-by: David Rheinsberg <david.rheinsberg@gmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD38
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5611cde5b9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Mar 2 14:11:53 UTC 2020
+pkgbase = osbuild
+ pkgdesc = Build Pipelines for Operating System Artifacts
+ pkgver = 8+50+g83d058b
+ pkgrel = 1
+ url = https://www.osbuild.org
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ source = git+https://github.com/osbuild/osbuild#commit=83d058b9354c4169f08b5d42851e5cbc07354532
+ sha256sums = SKIP
+
+pkgname = osbuild
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f13c7a9bb101
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.gz
+*.xz
+*.zst
+*-git/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b39e7914f0a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: David Rheinsberg <david.rheinsberg@gmail.com>
+
+pkgname=osbuild
+pkgver=8+50+g83d058b
+pkgrel=1
+pkgdesc="Build Pipelines for Operating System Artifacts"
+url="https://www.osbuild.org"
+arch=(any)
+license=(Apache)
+depends=(python)
+makedepends=(python-setuptools)
+_commit=83d058b9354c4169f08b5d42851e5cbc07354532
+source=("git+https://github.com/osbuild/osbuild#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --skip-build --root="$pkgdir"
+
+ for group in assemblers runners sources stages ; do
+ install -v -m 0755 -d "$pkgdir/usr/lib/osbuild"
+ cp -vdr --no-preserve=ownership "$group" "$pkgdir/usr/lib/osbuild/"
+ rm -vf "$pkgdir/usr/lib/osbuild/$group/osbuild"
+ install -v -m 0755 -d "$pkgdir/usr/lib/osbuild/$group/osbuild"
+ done
+}
+
+# vim:set sw=2 et: