summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Gatto2020-08-04 11:44:21 +0200
committerMatthias Gatto2020-08-04 11:44:21 +0200
commit5e8683e01983f35eb7208223efdd8408764fe686 (patch)
tree472660bcc0671d8b4f28617ad117bd2f7d1e3776
parent1e98b384e414db72b57b086e3f906303784e44dc (diff)
downloadaur-5e8683e01983f35eb7208223efdd8408764fe686.tar.gz
add pkgver()
Signed-off-by: Matthias Gatto <matthias.gatto@outscale.com>
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99f042af4a20..77e33f546e50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Reference: PKGBUILD(5)
pkgname=osc-cli-git
-pkgver=1.5
+pkgver=v1.5.0.r0.gd4e7746
pkgrel=1
pkgdesc='Outscale CLI'
@@ -10,6 +10,11 @@ arch=('any')
url='https://github.com/outscale/osc-cli'
license=(BSD)
+pkgver() {
+ cd "${srcdir}/osc-cli"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
makedepends=('python-setuptools')
depends=(python-fire python-requests python-xmltodict)