summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2016-03-19 21:18:46 +0100
committerJulian Xhokaxhiu2016-03-19 21:18:46 +0100
commit43b9b96faa9f072a8f6862654b0657ef23866cb2 (patch)
tree96510c8e4da18ba85229cd3624d4868ec9975ebe
parentcfa8a25705e91083af1873cdb0c750e15bbf64bf (diff)
downloadaur-43b9b96faa9f072a8f6862654b0657ef23866cb2.tar.gz
Add patch to fix SSLv3 compilation issue.
Thanks to https://github.com/VDR4Arch/vdr4arch for this!
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
-rw-r--r--oscam-remove-sslv3.diff25
3 files changed, 35 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 367baaa75520..b918ca26c5b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = oscam-git
pkgdesc = Open Source Conditional Access Module software
pkgver = 11213
- pkgrel = 1
+ pkgrel = 2
url = http://www.streamboard.tv/oscam
install = oscam.install
arch = x86_64
@@ -17,6 +17,7 @@ pkgbase = oscam-git
optdepends = pcsclite: for use with PC/SC readers
optdepends = ccid: PC/SC reader generic driver
source = git+http://www.oscam.cc/git/oscam-mirror#commit=64c739f95fe4f6f9dbf0d6693606743185c15ff6
+ source = oscam-remove-sslv3.diff
source = oscam.service
source = oscam.sysuser
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index de4a521abf44..240e98d427f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=oscam-git
pkgver=11213
_gitrev=64c739f95fe4f6f9dbf0d6693606743185c15ff6
-pkgrel=1
+pkgrel=2
pkgdesc="Open Source Conditional Access Module software"
url="http://www.streamboard.tv/oscam"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -17,9 +17,11 @@ optdepends=('pcsclite: for use with PC/SC readers'
'ccid: PC/SC reader generic driver')
install='oscam.install'
source=("git+http://www.oscam.cc/git/oscam-mirror#commit=$_gitrev"
+ 'oscam-remove-sslv3.diff'
'oscam.service'
'oscam.sysuser')
md5sums=('SKIP'
+ '6dbe54b15419308a343bea08aad6d65c'
'596b902e3f4a66d39e7f993437feec74'
'be0d9d7a5fdd8cf4918c4ea91cebd989')
@@ -28,6 +30,11 @@ pkgver() {
git log -1 | grep git-svn-id | cut -d'@' -f2 | cut -d' ' -f1
}
+prepare() {
+ cd "$srcdir/oscam-mirror"
+ patch -p1 -i "$srcdir/oscam-replace-sslv3.diff"
+}
+
build() {
cd "$srcdir/oscam-mirror"
diff --git a/oscam-remove-sslv3.diff b/oscam-remove-sslv3.diff
new file mode 100644
index 000000000000..cf4e82b79448
--- /dev/null
+++ b/oscam-remove-sslv3.diff
@@ -0,0 +1,25 @@
+diff --git a/module-webif-lib.c b/module-webif-lib.c
+index bda2286..06f97fe 100644
+--- a/module-webif-lib.c
++++ b/module-webif-lib.c
+@@ -864,19 +864,7 @@ SSL_CTX *SSL_Webif_Init(void)
+ CRYPTO_set_dynlock_lock_callback(SSL_dyn_lock_function);
+ CRYPTO_set_dynlock_destroy_callback(SSL_dyn_destroy_function);
+
+- if(cfg.http_force_sslv3)
+- {
+- ctx = SSL_CTX_new(SSLv3_server_method());
+-#ifdef SSL_CTX_clear_options
+- SSL_CTX_clear_options(ctx, SSL_OP_ALL); //we CLEAR all bug workarounds! This is for security reason
+-#else
+- cs_log("WARNING: You enabled to force sslv3 but your system does not support to clear the ssl workarounds! SSL security will be reduced!");
+-#endif
+- SSL_CTX_set_options(ctx, SSL_OP_NO_SSLv2); // we force SSL v3 !
+- SSL_CTX_set_cipher_list(ctx, SSL_TXT_RC4);
+- }
+- else
+- { ctx = SSL_CTX_new(SSLv23_server_method()); }
++ ctx = SSL_CTX_new(SSLv23_server_method());
+
+ char path[128];
+