summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2016-12-11 17:43:31 +0100
committerJulian Xhokaxhiu2016-12-11 17:43:31 +0100
commit50053572538f7b281192b39e609a2606f0323fa3 (patch)
tree3ca614095a2ac70bb5b097d39b8babfa1e37ba17
parentd8216a27ab2071b19d04f9b4d1ef3982be51e560 (diff)
downloadaur-50053572538f7b281192b39e609a2606f0323fa3.tar.gz
Shift again to the original oscam project
It seems that the new one has some issues on handling readers
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b2d7496728b..f503b6419aa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oscam-git
pkgdesc = Open Source Conditional Access Module software
- pkgver = r10293.9cf1393
+ pkgver = 11286
pkgrel = 1
url = http://www.streamboard.tv/oscam
install = oscam.install
@@ -16,7 +16,7 @@ pkgbase = oscam-git
depends = openssl
optdepends = pcsclite: for use with PC/SC readers
optdepends = ccid: PC/SC reader generic driver
- source = git+https://github.com/nx111/oscam.git
+ source = git+http://www.oscam.cc/git/oscam-mirror
source = oscam.service
source = oscam.sysuser
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3b966fdcafb6..74a0280a691b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Author: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
# Maintainer: Julian Xhokaxhiu <info@julianxhokaxhiu.com>
pkgname=oscam-git
-pkgver=r10293.9cf1393
+pkgver=11286
pkgrel=1
pkgdesc="Open Source Conditional Access Module software"
url="http://www.streamboard.tv/oscam"
@@ -15,7 +15,7 @@ makedepends=('git' 'pcsclite')
optdepends=('pcsclite: for use with PC/SC readers'
'ccid: PC/SC reader generic driver')
install='oscam.install'
-source=("git+https://github.com/nx111/oscam.git"
+source=("git+http://www.oscam.cc/git/oscam-mirror"
'oscam.service'
'oscam.sysuser')
md5sums=('SKIP'
@@ -23,12 +23,12 @@ md5sums=('SKIP'
'be0d9d7a5fdd8cf4918c4ea91cebd989')
pkgver() {
- cd "$srcdir/oscam"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/oscam-mirror"
+ git log -1 | grep git-svn-id | cut -d'@' -f2 | cut -d' ' -f1
}
build() {
- cd "$srcdir/oscam"
+ cd "$srcdir/oscam-mirror"
make CONF_DIR=/var/lib/oscam \
USE_SSL=1 \
@@ -40,7 +40,7 @@ build() {
}
package() {
- cd "$srcdir/oscam"
+ cd "$srcdir/oscam-mirror"
#Install binaries
install -Dm755 oscam "$pkgdir/usr/bin/oscam"