summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2016-07-03 16:12:59 +0200
committerJulian Xhokaxhiu2016-07-03 16:12:59 +0200
commitce89d3daef6af03ccf214cfe1a7b3bb7da45a6a5 (patch)
treeac3ab236eff51a5b2e94362132a9b8a193f996b9
parent50ff01af4cb28de8657576867d62d084b9068615 (diff)
downloadaur-ce89d3daef6af03ccf214cfe1a7b3bb7da45a6a5.tar.gz
Bump version
And finally remove the SSLv3 patch. The original project fixed it once and for all!
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--oscam-remove-sslv3.diff25
3 files changed, 4 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a149ab67776..7b9d31b1e153 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oscam-git
pkgdesc = Open Source Conditional Access Module software
- pkgver = 11248
+ pkgver = 11271
pkgrel = 1
url = http://www.streamboard.tv/oscam
install = oscam.install
@@ -16,8 +16,7 @@ pkgbase = oscam-git
depends = openssl
optdepends = pcsclite: for use with PC/SC readers
optdepends = ccid: PC/SC reader generic driver
- source = git+http://www.oscam.cc/git/oscam-mirror#commit=32a05ea6ca7436ca36eede04a2890ec4338e31b6
- source = oscam-remove-sslv3.diff
+ source = git+http://www.oscam.cc/git/oscam-mirror#commit=d06d2de15cbc417e4c872df8110ec04f7563c9a6
source = oscam.service
source = oscam.sysuser
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b8f1361c2980..b3010f7eeae9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Author: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
# Maintainer: Julian Xhokaxhiu <info@julianxhokaxhiu.com>
pkgname=oscam-git
-pkgver=11248
-_gitrev=32a05ea6ca7436ca36eede04a2890ec4338e31b6
+pkgver=11271
+_gitrev=d06d2de15cbc417e4c872df8110ec04f7563c9a6
pkgrel=1
pkgdesc="Open Source Conditional Access Module software"
url="http://www.streamboard.tv/oscam"
@@ -17,11 +17,9 @@ optdepends=('pcsclite: for use with PC/SC readers'
'ccid: PC/SC reader generic driver')
install='oscam.install'
source=("git+http://www.oscam.cc/git/oscam-mirror#commit=$_gitrev"
- 'oscam-remove-sslv3.diff'
'oscam.service'
'oscam.sysuser')
md5sums=('SKIP'
- '6dbe54b15419308a343bea08aad6d65c'
'596b902e3f4a66d39e7f993437feec74'
'be0d9d7a5fdd8cf4918c4ea91cebd989')
@@ -30,11 +28,6 @@ pkgver() {
git log -1 | grep git-svn-id | cut -d'@' -f2 | cut -d' ' -f1
}
-prepare() {
- cd "$srcdir/oscam-mirror"
- patch -p1 -i "$srcdir/oscam-remove-sslv3.diff"
-}
-
build() {
cd "$srcdir/oscam-mirror"
diff --git a/oscam-remove-sslv3.diff b/oscam-remove-sslv3.diff
deleted file mode 100644
index cf4e82b79448..000000000000
--- a/oscam-remove-sslv3.diff
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/module-webif-lib.c b/module-webif-lib.c
-index bda2286..06f97fe 100644
---- a/module-webif-lib.c
-+++ b/module-webif-lib.c
-@@ -864,19 +864,7 @@ SSL_CTX *SSL_Webif_Init(void)
- CRYPTO_set_dynlock_lock_callback(SSL_dyn_lock_function);
- CRYPTO_set_dynlock_destroy_callback(SSL_dyn_destroy_function);
-
-- if(cfg.http_force_sslv3)
-- {
-- ctx = SSL_CTX_new(SSLv3_server_method());
--#ifdef SSL_CTX_clear_options
-- SSL_CTX_clear_options(ctx, SSL_OP_ALL); //we CLEAR all bug workarounds! This is for security reason
--#else
-- cs_log("WARNING: You enabled to force sslv3 but your system does not support to clear the ssl workarounds! SSL security will be reduced!");
--#endif
-- SSL_CTX_set_options(ctx, SSL_OP_NO_SSLv2); // we force SSL v3 !
-- SSL_CTX_set_cipher_list(ctx, SSL_TXT_RC4);
-- }
-- else
-- { ctx = SSL_CTX_new(SSLv23_server_method()); }
-+ ctx = SSL_CTX_new(SSLv23_server_method());
-
- char path[128];
-