summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorharre2020-03-08 02:13:35 +0100
committerharre2020-03-08 02:13:35 +0100
commit4f9aa030a28f6287fa4b26a5b8d3f4c5e50ebf1f (patch)
tree853d0e7a7c591de12de0279e41b5f40294ab3f5f
parent7e32de7db7a7e5036a905186f66a78502ad06c9f (diff)
downloadaur-4f9aa030a28f6287fa4b26a5b8d3f4c5e50ebf1f.tar.gz
Removed permissive patch as i has been fixed upstream
-rw-r--r--PKGBUILD3
-rw-r--r--permissive.patch15
2 files changed, 1 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e107c8ff865..5094df49756d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jason Lenz <Jason@Lenzplace.org>
_pkgname=oscar
pkgname=oscar-git
-pkgver=..r3202.1b105c15
+pkgver=..r3245.aaaaef0d
pkgrel=1
pkgdesc="Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment. Fork of the sleepyhead project."
arch=('i686' 'x86_64')
@@ -35,7 +35,6 @@ pkgver() {
build() {
cd OSCAR-code
- git apply ../../permissive.patch
qmake OSCAR_QT.pro
make -j$(cat /proc/cpuinfo | awk '/^processor/{print $3}' | wc -l)
}
diff --git a/permissive.patch b/permissive.patch
deleted file mode 100644
index 61ea5c889025..000000000000
--- a/permissive.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/oscar/oscar.pro b/oscar/oscar.pro
-index 24a68f10..dc223c87 100644
---- a/oscar/oscar.pro
-+++ b/oscar/oscar.pro
-@@ -488,6 +488,10 @@ QMAKE_CXXFLAGS += -Werror
- # Make deprecation warnings just warnings
- QMAKE_CFLAGS += -Wno-error=deprecated-declarations
- QMAKE_CXXFLAGS += -Wno-error=deprecated-declarations
-+
-+# Make g++ more permissive
-+QMAKE_CXXFLAGS += -fpermissive
-+
- lessThan(QT_MAJOR_VERSION,5)|lessThan(QT_MINOR_VERSION,9) {
- QMAKE_CFLAGS += -Wno-error=strict-aliasing
- QMAKE_CXXFLAGS += -Wno-error=strict-aliasing