summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Hartung2022-02-18 01:26:00 +0100
committerMarkus Hartung2022-02-18 01:26:00 +0100
commit8dc3c3acc8d55c13bcbd5d9116c4298250b28fad (patch)
treeb8c212401c175180285380c15d47d7bcddbf71d1
parent78df6826d5ed2a7ec8b60a4d17135d2018bb67c7 (diff)
downloadaur-8dc3c3acc8d55c13bcbd5d9116c4298250b28fad.tar.gz
Fix ODR-violation until fixed in upstream
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--odr-fix.patch14
3 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5300639401d8..b0bd4ee83286 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oscar-git
pkgdesc = Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment. Fork of the sleepyhead project.
- pkgver = ..r3833.81856e08
+ pkgver = ..r4010.df17e279
pkgrel = 1
url = https://gitlab.com/pholy/OSCAR-code
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index cfa0c2d7fa3b..8fda5ea64e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jason Lenz <Jason@Lenzplace.org>
_pkgname=oscar
pkgname=oscar-git
-pkgver=..r3833.81856e08
+pkgver=..r4010.df17e279
pkgrel=1
pkgdesc="Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment. Fork of the sleepyhead project."
arch=('i686' 'x86_64')
diff --git a/odr-fix.patch b/odr-fix.patch
new file mode 100644
index 000000000000..d595d1ba198e
--- /dev/null
+++ b/odr-fix.patch
@@ -0,0 +1,14 @@
+diff --git a/oscar/oscar.pro b/oscar/oscar.pro
+index ed8195e5..116ec8b9 100644
+--- a/oscar/oscar.pro
++++ b/oscar/oscar.pro
+@@ -546,6 +546,9 @@ gcc | clang {
+ QMAKE_CFLAGS += -Wno-error=deprecated-declarations
+ QMAKE_CXXFLAGS += -Wno-error=deprecated-declarations
+
++# Ignore ODR-violations until fixed in upstream: https://gitlab.com/pholy/OSCAR-code/-/issues/52
++QMAKE_CXXFLAGS += -Wno-error=odr
++
+ lessThan(QT_MAJOR_VERSION,5)|lessThan(QT_MINOR_VERSION,9) {
+ QMAKE_CFLAGS += -Wno-error=strict-aliasing
+ QMAKE_CXXFLAGS += -Wno-error=strict-aliasing