summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:07:57 +0100
committermschubert2015-06-12 12:07:57 +0100
commit7290acff7dc50514be836c593979fba163a588f2 (patch)
treef42936b165c4414768d0f941b00f624f06bbb8c3
downloadaur-7290acff7dc50514be836c593979fba163a588f2.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
-rw-r--r--oscill8_starter2
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0a90fb10413
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = oscill8
+ pkgdesc = Time course, parameter scan and bifurcation analysis of ODE systems
+ pkgver = 2.0.11
+ pkgrel = 1
+ url = http://oscill8.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = mono
+ source = http://sourceforge.net/projects/oscill8/files/oscill8/2.0.11/oscill8_mac_manual_setup.zip/download
+ source = oscill8_starter
+ md5sums = 53bf86373bb4245414ac6c67a3cfe99c
+ md5sums = 4411a2ae23364fabb6aae78862894daa
+
+pkgname = oscill8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47b8f8b83251
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=oscill8
+pkgver=2.0.11
+pkgrel=1
+pkgdesc='Time course, parameter scan and bifurcation analysis of ODE systems'
+arch=('i686' 'x86_64')
+url=('http://oscill8.sourceforge.net/')
+license=('BSD')
+depends=('mono')
+source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/oscill8_mac_manual_setup.zip/download" "oscill8_starter")
+md5sums=('53bf86373bb4245414ac6c67a3cfe99c'
+ '4411a2ae23364fabb6aae78862894daa')
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ cp -R "$srcdir/oscill8" "$pkgdir/opt"
+ install -Dm755 oscill8_starter "$pkgdir/usr/bin/oscill8"
+}
diff --git a/oscill8_starter b/oscill8_starter
new file mode 100644
index 000000000000..4338c911a97d
--- /dev/null
+++ b/oscill8_starter
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec mono /opt/oscill8/oscill8.exe