summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchadept2015-06-27 10:00:27 +0200
committerArchadept2015-06-27 10:00:27 +0200
commitfddb7bdf703a7ecd23c4e3bfc8c79c56db3aa7b9 (patch)
tree7d829076e64ed9c4b0a4eb0607ea9b4473e1c346
downloadaur-fddb7bdf703a7ecd23c4e3bfc8c79c56db3aa7b9.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--index.theme129
3 files changed, 170 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d697fcc2ebf1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = osdark-rfx-green
+ pkgdesc = Green icon theme for xfce
+ pkgver = 20120211
+ pkgrel = 1
+ url = http://xfce-look.org/content/show.php/OSDark+RFX?content=139893
+ arch = any
+ license = GPL
+ source = https://dl.dropbox.com/u/72894581/OSDark-green-20120211.tar.bz2
+ source = http://xfce-look.org/CONTENT/content-files/139892-OSDark-dist-20120211.tar.bz2
+ source = index.theme
+ md5sums = 057edbb93e2a3ba049173ce9a45d0411
+ md5sums = dfe1720c7e5c2a750a7d38afc395bac3
+ md5sums = bb175e512d5a714bdc7a041f19d4e82c
+
+pkgname = osdark-rfx-green
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27183e11d3ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Archadept
+# Revision: 2015-06-27
+
+pkgname=osdark-rfx-green
+pkgver=20120211
+pkgrel=1
+pkgdesc="Green icon theme for xfce"
+url="http://xfce-look.org/content/show.php/OSDark+RFX?content=139893"
+arch=(any)
+license=('GPL')
+source=(https://dl.dropbox.com/u/72894581/OSDark-green-$pkgver.tar.bz2 http://xfce-look.org/CONTENT/content-files/139892-OSDark-dist-$pkgver.tar.bz2 index.theme)
+md5sums=('057edbb93e2a3ba049173ce9a45d0411'
+'dfe1720c7e5c2a750a7d38afc395bac3'
+'bb175e512d5a714bdc7a041f19d4e82c')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/icons/"
+ # Installing theme
+ cp -R $startdir/src/OSDark-green $pkgdir/usr/share/icons/
+ cp $startdir/src/OSDark-dist/arch.png $pkgdir/usr/share/icons/OSDark-green/128x128/places/start-here.png
+ cp $startdir/src/OSDark-dist/arch-16.png $pkgdir/usr/share/icons/OSDark-green/16x16/places/start-here.png
+ cp $startdir/src/OSDark-dist/emblem-arch.png $pkgdir/usr/share/icons/OSDark-green/128x128/emblems/emblem-arch.png
+ # Updating index
+ cp $startdir/index.theme $pkgdir/usr/share/icons/OSDark-green/
+}
diff --git a/index.theme b/index.theme
new file mode 100644
index 000000000000..6bacedb93bff
--- /dev/null
+++ b/index.theme
@@ -0,0 +1,129 @@
+[Icon Theme]
+Name=OSDark-green
+Comment=Dark icons for xfce (green variant)
+Inherits=gnome, hicolor
+Example=folder
+
+Directories=128x128/emotes,128x128/actions,48x48/actions,24x24/actions,16x16/actions,128x128/apps,16x16/apps,128x128/categories,16x16/categories,128x128/devices,16x16/devices,128x128/emblems,128x128/mimetypes,16x16/mimetypes,128x128/places,16x16/places,128x128/status,48x48/status,24x24/status,16x16/status
+
+[128x128/actions]
+Size=128
+MinSize=50
+MaxSize=128
+Context=Actions
+Type=Scalable
+
+[48x48/actions]
+Size=48
+MinSize=26
+MaxSize=48
+Context=Actions
+Type=Scalable
+
+[24x24/actions]
+Size=24
+Context=Actions
+Type=Fixed
+
+[16x16/actions]
+Size=16
+Context=Actions
+Type=Fixed
+
+[128x128/apps]
+Size=128
+MinSize=18
+MaxSize=128
+Context=Applications
+Type=Scalable
+
+[16x16/apps]
+Size=16
+Context=Applications
+Type=Fixed
+
+[128x128/categories]
+Size=128
+MinSize=18
+MaxSize=128
+Context=Categories
+Type=Scalable
+
+[16x16/categories]
+Size=16
+Context=Categories
+Type=Fixed
+
+[128x128/devices]
+Size=128
+MinSize=18
+MaxSize=128
+Context=Devices
+Type=Scalable
+
+[16x16/devices]
+Size=16
+Context=Devices
+Type=Fixed
+
+[128x128/emblems]
+Size=128
+MinSize=16
+MaxSize=128
+Context=Emblems
+Type=Scalable
+
+[128x128/emotes]
+Size=128
+MinSize=16
+MaxSize=128
+Context=Emotes
+Type=Scalable
+
+[128x128/mimetypes]
+Size=128
+MinSize=18
+MaxSize=128
+Context=MimeTypes
+Type=Scalable
+
+[16x16/mimetypes]
+Size=16
+Context=MimeTypes
+Type=Fixed
+
+[128x128/places]
+Size=128
+MinSize=18
+MaxSize=128
+Context=Places
+Type=Scalable
+
+[16x16/places]
+Size=16
+Context=Places
+Type=Fixed
+
+[128x128/status]
+Size=128
+MinSize=50
+MaxSize=128
+Context=Status
+Type=Scalable
+
+[48x48/status]
+Size=48
+MinSize=26
+MaxSize=48
+Context=Status
+Type=Scalable
+
+[24x24/status]
+Size=24
+Context=Status
+Type=Fixed
+
+[16x16/status]
+Size=16
+Context=Status
+Type=Fixed