summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOndřej Svoboda2015-12-15 23:45:40 +0000
committerOndřej Svoboda2015-12-15 23:45:40 +0000
commit3e47b624beefe8a790943de0a0bdcab1bfa9d42b (patch)
treea83ef4df85637b28f6ccc491241df88d8b6e5b31
downloadaur-3e47b624beefe8a790943de0a0bdcab1bfa9d42b.tar.gz
osdlyrics-git: community fork slowly making it to 0.5 release
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD40
-rw-r--r--osdlyrics.install15
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01efc3462c61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Tue Dec 15 23:45:25 UTC 2015
+pkgbase = osdlyrics-git
+ pkgdesc = Standalone lyrics fetcher/displayer (windowed and OSD mode). Supports MPRIS1/2 players, and MPD.
+ pkgver = 0.4.99.r817.3fe2571
+ pkgrel = 1
+ url = https://github.com/PedroHLC/osdlyrics
+ install = osdlyrics.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = gtk2
+ depends = hicolor-icon-theme
+ depends = libnotify
+ depends = python2-dbus
+ depends = python2-chardet
+ depends = python2-gobject2
+ depends = python2-pycurl
+ depends = sqlite
+ optdepends = gobject-introspection-runtime: proxy detection in Gnome
+ optdepends = kdebindings-python2: proxy detection in KDE
+ optdepends = python2-mpd: to interface with MPD
+ provides = osdlyrics
+ conflicts = osdlyrics
+ conflicts = osdlyrics-pedrohlc
+ source = osdlyrics::git+git://github.com/PedroHLC/osdlyrics.git#branch=master
+ md5sums = SKIP
+
+pkgname = osdlyrics-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e987e94ba60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Ondřej Svoboda <ondrej@svobodasoft.cz>
+pkgname=osdlyrics-git
+provides=osdlyrics
+conflicts=(osdlyrics osdlyrics-pedrohlc)
+_pkgver=0.4.99
+pkgver=0.4.99.r817.3fe2571
+pkgrel=1
+pkgdesc="Standalone lyrics fetcher/displayer (windowed and OSD mode). Supports MPRIS1/2 players, and MPD."
+arch=(i686 x86_64)
+url="https://github.com/PedroHLC/osdlyrics"
+license=(GPL3)
+depends=(dbus-glib desktop-file-utils gtk2 hicolor-icon-theme libnotify
+ python2-dbus python2-chardet python2-gobject2 python2-pycurl
+ sqlite)
+makedepends=(intltool)
+optdepends=('gobject-introspection-runtime: proxy detection in Gnome'
+ 'kdebindings-python2: proxy detection in KDE'
+ 'python2-mpd: to interface with MPD')
+install=$provides.install
+source=("${provides}::git+git://github.com/PedroHLC/osdlyrics.git#branch=master")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$provides"
+ printf "$_pkgver.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd "$srcdir/$provides"
+ ./autogen.sh
+ ./configure --prefix=/usr PYTHON=/usr/bin/python2
+ make
+}
+
+package()
+{
+ cd "$srcdir/$provides"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/osdlyrics.install b/osdlyrics.install
new file mode 100644
index 000000000000..54854a1fe7a5
--- /dev/null
+++ b/osdlyrics.install
@@ -0,0 +1,15 @@
+post_upgrade()
+{
+ usr/bin/update-desktop-database -q
+ usr/bin/gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install()
+{
+ post_upgrade
+}
+
+post_remove()
+{
+ post_upgrade
+}