summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2019-12-14 18:20:51 -0500
committerSamuel Mesa2019-12-14 18:20:51 -0500
commit381afaed9bdb5cfe89b1ce6b48f94a9d0940f4e2 (patch)
tree761084c5e2f4465328503ad12d6f6b0c6fe061d1
parent509e4d736d03e49bddd30faccd7c4d51f513a8a2 (diff)
downloadaur-381afaed9bdb5cfe89b1ce6b48f94a9d0940f4e2.tar.gz
Update to version 2.10.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--geos-3_8-support.patch69
3 files changed, 87 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf68993badec..6711c3d002cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = osgearth
pkgdesc = A terrain rendering toolkit for OpenSceneGraph
- pkgver = 2.10.1
- pkgrel = 1
+ pkgver = 2.10.2
+ pkgrel = 2
url = http://www.osgearth.org
arch = i686
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = osgearth
depends = rocksdb
depends = duktape
provides = osgearth
- source = https://github.com/gwaldron/osgearth/archive/osgearth-2.10.1.tar.gz
- md5sums = d780ccc0735130ff79b3f1b39e377960
+ source = https://github.com/gwaldron/osgearth/archive/osgearth-2.10.2.tar.gz
+ source = geos-3_8-support.patch
+ md5sums = 24f01afedb2eeac8154bf64772b7cbc7
+ md5sums = 590959bbe04444efc63f96f4b48db6ac
pkgname = osgearth
diff --git a/PKGBUILD b/PKGBUILD
index e788e6d32003..e93a37446f94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: A. Weiss <adam [at] archlinux.us>
pkgname=osgearth
-pkgver=2.10.1
-pkgrel=1
+pkgver=2.10.2
+pkgrel=2
pkgdesc="A terrain rendering toolkit for OpenSceneGraph"
arch=('i686' 'x86_64')
url='http://www.osgearth.org'
@@ -12,8 +12,16 @@ license=('LGPL')
depends=('openscenegraph' 'gdal' 'minizip' 'qt5-base' 'rocksdb' 'duktape')
makedepends=('cmake')
provides=('osgearth')
-source=("https://github.com/gwaldron/osgearth/archive/${pkgname}-${pkgver}.tar.gz")
-md5sums=('d780ccc0735130ff79b3f1b39e377960')
+source=("https://github.com/gwaldron/osgearth/archive/${pkgname}-${pkgver}.tar.gz"
+ "geos-3_8-support.patch")
+md5sums=('24f01afedb2eeac8154bf64772b7cbc7'
+ '590959bbe04444efc63f96f4b48db6ac')
+
+
+prepare(){
+ cd ${srcdir}/${pkgname}-${pkgname}-${pkgver}
+ patch -p1 < ../geos-3_8-support.patch
+}
build() {
cd ${srcdir}/${pkgname}-${pkgname}-${pkgver}
diff --git a/geos-3_8-support.patch b/geos-3_8-support.patch
new file mode 100644
index 000000000000..5993d4cb0c85
--- /dev/null
+++ b/geos-3_8-support.patch
@@ -0,0 +1,69 @@
+diff -Nur osgearth-osgearth-2.10.2.a/src/osgEarthSymbology/GEOS.cpp osgearth-osgearth-2.10.2.b/src/osgEarthSymbology/GEOS.cpp
+--- osgearth-osgearth-2.10.2.a/src/osgEarthSymbology/GEOS.cpp 2019-07-12 08:49:14.000000000 -0700
++++ osgearth-osgearth-2.10.2.b/src/osgEarthSymbology/GEOS.cpp 2019-11-16 10:00:08.966241888 -0800
+@@ -49,7 +49,7 @@
+
+ namespace
+ {
+- geom::CoordinateSequence*
++ std::unique_ptr<geom::CoordinateSequence>
+ vec3dArray2CoordSeq( const Symbology::Geometry* input, bool close, const geom::CoordinateSequenceFactory* factory )
+ {
+ bool needToClose = close && input->size() > 2 && input->front() != input->back();
+@@ -64,7 +64,7 @@
+ {
+ coords->push_back( coords->front() );
+ }
+- geom::CoordinateSequence* seq = factory->create( coords );
++ std::unique_ptr<geom::CoordinateSequence> seq = factory->create( coords );
+
+ return seq;
+ }
+@@ -108,7 +108,8 @@
+ else
+ {
+ // any other type will at least contain points:
+- geom::CoordinateSequence* seq = 0L;
++ std::unique_ptr<geom::CoordinateSequence> seq = 0L;
++
+ try
+ {
+ switch( input->getType() )
+@@ -119,24 +120,24 @@
+
+ case Symbology::Geometry::TYPE_POINTSET:
+ seq = vec3dArray2CoordSeq( input, false, f->getCoordinateSequenceFactory() );
+- if ( seq ) output = f->createPoint( seq );
++ if ( seq ) output = f->createPoint( *seq );
+ break;
+
+ case Symbology::Geometry::TYPE_LINESTRING:
+ seq = vec3dArray2CoordSeq( input, false, f->getCoordinateSequenceFactory() );
+- if ( seq ) output = f->createLineString( seq );
++ if ( seq ) output = f->createLineString( *seq );
+ break;
+
+ case Symbology::Geometry::TYPE_RING:
+ seq = vec3dArray2CoordSeq( input, true, f->getCoordinateSequenceFactory() );
+- if ( seq ) output = f->createLinearRing( seq );
++ if ( seq ) output = f->createLinearRing( *seq );
+ break;
+
+ case Symbology::Geometry::TYPE_POLYGON:
+ seq = vec3dArray2CoordSeq( input, true, f->getCoordinateSequenceFactory() );
+ geom::LinearRing* shell = 0L;
+ if ( seq )
+- shell = f->createLinearRing( seq );
++ shell = f->createLinearRing( *seq );
+
+ if ( shell )
+ {
+@@ -155,7 +156,7 @@
+ holes = 0L;
+ }
+ }
+- output = f->createPolygon( shell, holes );
++ output = f->createPolygon( shell, (std::vector<geom::LinearRing * >*)holes );
+ }
+
+ break;