summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVilsol2022-05-26 07:50:26 +0300
committerVilsol2022-05-26 07:50:26 +0300
commit641008de8dcfc83952a51682f2d8e87f611f87d5 (patch)
tree31fe45f96c9e52798b24b383d1d3cf1a1e9b4a3b
downloadaur-641008de8dcfc83952a51682f2d8e87f611f87d5.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--.pre-commit13
-rw-r--r--PKGBUILD26
-rw-r--r--oshabi.desktop6
5 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a25ed20b5f30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = oshabi-bin
+ pkgdesc = A scanner for Path of Exile harvest horticrafting stations and sacred grove.
+ pkgver = 0.0.15
+ pkgrel = 1
+ url = https://github.com/Vilsol/oshabi
+ arch = x86_64
+ license = GPL3
+ depends = tesseract
+ depends = opencv
+ provides = oshabi=0.0.15
+ conflicts = oshabi
+ source = https://github.com/Vilsol/oshabi/releases/download/v0.0.15/oshabi-linux-amd64.tar.gz
+ source = oshabi.desktop
+ sha256sums = d47c871180a6a7e4be64b4c033908783d80e41943db3ec1b5f350fccccf8e161
+ sha256sums = 27038c830b270cc01df8fc989766e2eb444944a19230f4f25dae63c451456a9c
+
+pkgname = oshabi-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3313cbb6d9c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!/.SRCINFO
+!/.gitignore
+!/.pre-commit
+!/PKGBUILD
+!/oshabi.desktop \ No newline at end of file
diff --git a/.pre-commit b/.pre-commit
new file mode 100644
index 000000000000..0443fb00d3c0
--- /dev/null
+++ b/.pre-commit
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+# fix environment of githooks
+unset GIT_DIR
+# if PKGBUILD has been altered, update .SRCINFO
+for path in $(git diff --name-only --cached --diff-filter=AM); do
+ if [[ "${path}" =~ .*PKGBUILD$ ]]; then
+ echo -e "\e[01;32m *** Generating and adding .SRCINFO for ${path} ***\e[00m"
+ (makepkg --printsrcinfo > "${PWD}"/.SRCINFO) || exit 1
+ git update-index
+ git add "${PWD}"/.SRCINFO
+ fi
+done \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77ed390e5da6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Vilsol <me at vil dot so>
+
+pkgname=oshabi-bin
+pkgver=0.0.15
+pkgrel=1
+pkgdesc='A scanner for Path of Exile harvest horticrafting stations and sacred grove.'
+arch=(x86_64)
+url=https://github.com/Vilsol/oshabi
+license=(GPL3)
+depends=(tesseract
+ opencv)
+
+provides=("${pkgname/-bin/}=${pkgver}")
+conflicts=("${pkgname/-bin/}")
+
+source=("https://github.com/Vilsol/${pkgname/-bin/}/releases/download/v${pkgver}/${pkgname/-bin/}-linux-amd64.tar.gz"
+ "oshabi.desktop")
+
+sha256sums=('d47c871180a6a7e4be64b4c033908783d80e41943db3ec1b5f350fccccf8e161'
+ '27038c830b270cc01df8fc989766e2eb444944a19230f4f25dae63c451456a9c')
+
+package() {
+ _output="${srcdir}/${pkgname/-bin/}-linux-amd64-v${pkgver}"
+ install -Dm0755 "${_output}/${pkgname/-bin/}" "${pkgdir}/usr/bin/${pkgname/-bin/}"
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "oshabi.desktop"
+} \ No newline at end of file
diff --git a/oshabi.desktop b/oshabi.desktop
new file mode 100644
index 000000000000..6d3b482ddecd
--- /dev/null
+++ b/oshabi.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Version=1.0
+Name=Oshabi
+Exec=oshabi
+Terminal=false
+Type=Application