summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2015-06-09 13:14:34 +0200
committerValHue2015-06-09 13:14:34 +0200
commited2b18ebcfc959c38b1377a767e61f5b6f94a9d3 (patch)
tree6d831725643679c33d1427cfb3e6d91cd389d8ea
downloadaur-ed2b18ebcfc959c38b1377a767e61f5b6f94a9d3.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90259189f1ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = osmc-installer-bin
+ pkgdesc = OSMC Installer allows you to install OSMC on a variety of devices.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://osmc.tv
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ depends = gcc
+ depends = qt4
+ depends = gcc-libs
+ depends = zlib
+ provides = osmc-installer
+ source_i686 = http://download.opensuse.org/repositories/home:/osmc/Debian_7.0/i386/osmc-installer_111_i386.deb
+ md5sums_i686 = 04227d4d124baff3d0f7563ac42789eb
+ source_x86_64 = http://download.opensuse.org/repositories/home:/osmc/Debian_7.0/amd64/osmc-installer_111_amd64.deb
+ md5sums_x86_64 = c99942d619a7b7e06624251a95b83c33
+
+pkgname = osmc-installer-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3263d79298d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: Sam G Nazarko <email at samnazarko dot co dot uk>
+# Contributor: Luigi Ranghetti <ggranga at gmail dot com>
+
+pkgname="osmc-installer-bin"
+pkgver="1.1.1"
+pkgrel="1"
+pkgdesc="OSMC Installer allows you to install OSMC on a variety of devices."
+url="http://osmc.tv"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'gcc' 'qt4' 'gcc-libs' 'zlib')
+provides=('osmc-installer')
+
+source_i686=("http://download.opensuse.org/repositories/home:/osmc/Debian_7.0/i386/osmc-installer_${pkgver//./}_i386.deb")
+source_x86_64=("http://download.opensuse.org/repositories/home:/osmc/Debian_7.0/amd64/osmc-installer_${pkgver//./}_amd64.deb")
+md5sums_i686=('04227d4d124baff3d0f7563ac42789eb')
+md5sums_x86_64=('c99942d619a7b7e06624251a95b83c33')
+
+package() {
+ cd "${srcdir}"
+ ar p *.deb data.tar.gz | tar zx -C "${pkgdir}" ./usr
+
+ cd "${pkgdir}"
+ rm -rf ./usr/share/doc
+}
+
+# vim:set ts=4 sw=2 ft=sh et: