summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2022-02-07 21:53:27 +0100
committerAleksandar Trifunovic2022-02-07 21:53:27 +0100
commit10024014d610baa4365b9e99e1425f8dfe8df98e (patch)
treed46ae10c001c104ebf8449dd99dca85b4da19bb6
parent4787eb3faa7d85c94847efa1d11818fa14612334 (diff)
downloadaur-10024014d610baa4365b9e99e1425f8dfe8df98e.tar.gz
v1.14
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 072e4b4dbf50..9cc99326d3f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osmium-tool
pkgdesc = Command line tool for working with OpenStreetMap data based on the Osmium library
- pkgver = 1.13.2
+ pkgver = 1.14.0
pkgrel = 1
url = https://osmcode.org/osmium-tool/
arch = i686
@@ -11,7 +11,7 @@ pkgbase = osmium-tool
depends = boost-libs
depends = expat
optdepends = pandoc: building documentation
- source = osmium-tool-1.13.2.tar.gz::https://github.com/osmcode/osmium-tool/archive/v1.13.2.tar.gz
- sha256sums = a6516087bfe1f6c881c9087b448ee8965b7d1730e29e4e8e982cd2ef8c4f8d98
+ source = osmium-tool-1.14.0.tar.gz::https://github.com/osmcode/osmium-tool/archive/v1.14.0.tar.gz
+ sha256sums = 67765fe6b612e791aab276af601dd12410b70486946e983753f6b0442f915233
pkgname = osmium-tool
diff --git a/PKGBUILD b/PKGBUILD
index 1062f758cce7..a145bbf0c215 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+# Maintainer: Aleksandar Trifunovic <akstrfn@gmail.com>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
+
pkgname=osmium-tool
-pkgver=1.13.2
+pkgver=1.14.0
pkgrel=1
pkgdesc="Command line tool for working with OpenStreetMap data based on the Osmium library"
arch=('i686' 'x86_64')
@@ -10,13 +12,22 @@ optdepends=('pandoc: building documentation')
url="https://osmcode.org/osmium-tool/"
license=('GPL3')
source=("$pkgname-$pkgver.tar.gz::https://github.com/osmcode/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('67765fe6b612e791aab276af601dd12410b70486946e983753f6b0442f915233')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cmake -S. -Bbuild \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
+ -DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+}
build() {
- cd "$pkgname-$pkgver"
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ cd "$pkgname-$pkgver/build"
+ make
}
check() {
@@ -30,4 +41,3 @@ package() {
install -Dm644 ../zsh_completion/_osmium "${pkgdir}/usr/share/zsh/site-functions/_osmium"
}
-sha256sums=('a6516087bfe1f6c881c9087b448ee8965b7d1730e29e4e8e982cd2ef8c4f8d98')