summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2016-10-20 11:07:59 +0200
committerSimon Legner2016-10-20 11:07:59 +0200
commit4743611f0fd73aa3bd44f50cb8931e645460b8f6 (patch)
treed464c97bb6df5de9fcb38c98be7fd6164a1b663b
parenta8145dfa0cc0774c6d876a544d9983985b14a418 (diff)
downloadaur-4743611f0fd73aa3bd44f50cb8931e645460b8f6.tar.gz
Improve build
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c350a0a0781..9180c4009a64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=osmium-tool
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Command line tool for working with OpenStreetMap data based on the Osmium library"
arch=('i686' 'x86_64')
depends=('boost-libs' 'expat')
-makedepends=('cmake' 'libosmium')
+makedepends=('cmake' 'libosmium>=2.9.0')
url="http://osmcode.org/osmium-tool/"
license=('GPL3')
source=("https://github.com/osmcode/$pkgname/archive/v$pkgver.tar.gz")
build() {
cd "$pkgname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}