summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadim Yanitskiy2024-01-28 06:43:12 +0700
committerVadim Yanitskiy2024-01-28 06:43:12 +0700
commita77b95fa8912bacbc8de222d5ef05d821cded0a5 (patch)
tree6c61e4214f13008150126e6c3ba8fe6a76164e97
parent865feaa58aff8c8fa6c557f7a2809aa70212b2f1 (diff)
downloadaur-osmo-bts-git.tar.gz
update $pkgver, $pkgdesc, $source; add 'libosmo-netif' dep
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab7fa2d81455..d2f111c48acc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osmo-bts-git
- pkgdesc = Open Source GSM BTS (Base Transceiver Station) with A-bis/IP interface
- pkgver = 0.8.1.r218.g3933e93
+ pkgdesc = Osmocom's GSM BTS (Base Transceiver Station) with A-bis/IP interface
+ pkgver = 1.7.0.r53.ge94553a54
pkgrel = 1
url = https://osmocom.org/projects/osmobts
arch = i686
@@ -10,15 +10,14 @@ pkgbase = osmo-bts-git
license = GPL
makedepends = git
depends = libosmocore
- depends = talloc
depends = libosmo-abis
+ depends = libosmo-netif
+ depends = talloc
depends = ortp
- provides = osmo-bts
conflicts = osmo-bts
backup = etc/osmocom/osmo-bts-trx.cfg
backup = etc/osmocom/osmo-bts-virtual.cfg
- source = git+https://git.osmocom.org/osmo-bts
+ source = git+https://gitea.osmocom.org/cellular-infrastructure/osmo-bts.git
sha256sums = SKIP
pkgname = osmo-bts-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8c832ffa9d39..ae234b96fac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
pkgname=osmo-bts-git
-pkgver=0.8.1.r218.g3933e93
+pkgver=1.7.0.r53.ge94553a54
pkgrel=1
-pkgdesc="Open Source GSM BTS (Base Transceiver Station) with A-bis/IP interface"
+pkgdesc="Osmocom's GSM BTS (Base Transceiver Station) with A-bis/IP interface"
url="https://osmocom.org/projects/osmobts"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore' 'talloc' 'libosmo-abis' 'ortp')
+depends=('libosmocore' 'libosmo-abis' 'libosmo-netif' 'talloc' 'ortp')
makedepends=('git')
-provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-backup=('etc/osmocom/osmo-bts-trx.cfg' 'etc/osmocom/osmo-bts-virtual.cfg')
-source=("git+https://git.osmocom.org/${pkgname%-git}")
+backup=('etc/osmocom/osmo-bts-trx.cfg'
+ 'etc/osmocom/osmo-bts-virtual.cfg')
+source=("git+https://gitea.osmocom.org/cellular-infrastructure/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
@@ -27,7 +28,10 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-trx
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-trx
make
}