summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-07 20:48:35 +0100
committerJosef Miegl2019-02-07 20:48:35 +0100
commit02a5f4ce7db6cb1f60c98385d9084fc94841efb3 (patch)
tree1cd29fa0468d43237039780621df9ccbaad3d437
parentdb8b880bb3d93a324cc9a3e7f492e4e697728eaa (diff)
downloadaur-02a5f4ce7db6cb1f60c98385d9084fc94841efb3.tar.gz
add makedepends, backup, style
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 28 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03181d8805f8..faade88bb1cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
pkgbase = osmo-bts-git
- pkgdesc = OsmoBTS is an Open Source GSM BTS (Base Transceiver Station) with A-bis/IP interface.
+ pkgdesc = Open Source GSM BTS (Base Transceiver Station) with A-bis/IP interface
pkgver = 0.8.1.205.g5c20563
pkgrel = 1
url = https://osmocom.org/projects/osmobts
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
license = GPL
+ makedepends = git
depends = libosmocore
depends = libosmo-abis
+ depends = ortp
provides = osmo-bts
conflicts = osmo-bts
- source = git://git.osmocom.org/osmo-bts
+ backup = etc/osmocom/osmo-bts-trx.cfg
+ backup = etc/osmocom/osmo-bts-virtual.cfg
+ source = git+https://git.osmocom.org/osmo-bts
sha256sums = SKIP
pkgname = osmo-bts-git
diff --git a/PKGBUILD b/PKGBUILD
index 60ae6a600d57..5f15d8d8f42d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
pkgname=osmo-bts-git
-_pkgname=osmo-bts
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
pkgver=0.8.1.205.g5c20563
pkgrel=1
-pkgdesc="OsmoBTS is an Open Source GSM BTS (Base Transceiver Station) with A-bis/IP interface."
+pkgdesc="Open Source GSM BTS (Base Transceiver Station) with A-bis/IP interface"
url="https://osmocom.org/projects/osmobts"
-arch=('any')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore' 'libosmo-abis')
-source=("git://git.osmocom.org/${_pkgname}")
+depends=('libosmocore' 'libosmo-abis' 'ortp')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+backup=('etc/osmocom/osmo-bts-trx.cfg' 'etc/osmocom/osmo-bts-virtual.cfg')
+source=("git+https://git.osmocom.org/${pkgname%-git}")
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
- echo $(git describe --always | sed 's/-/./g')
+ cd "${srcdir}/${pkgname%-git}"
+ echo $(git describe --always | sed 's/-/./g')
}
build() {
- cd "${srcdir}/${_pkgname}"
- autoreconf -i
- ./configure --prefix=/usr --enable-trx
- make
+ cd "${srcdir}/${pkgname%-git}"
+ autoreconf -i
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-trx
+ make
}
package() {
- cd "${srcdir}/${_pkgname}"
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname%-git}"
+ make DESTDIR=${pkgdir} install
}
+
+# vim:set ts=2 sw=2 et: