summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-07 21:09:26 +0100
committerJosef Miegl2019-02-07 21:09:26 +0100
commit4afda865850dad642e6915bdcd860428a2cc10a9 (patch)
treec83b14113c5f860211a04a92ca9b0a3a551cf875
parent58bbd8d9b93cd3f11f35a0b2ccfc560a2eac8ecb (diff)
downloadaur-4afda865850dad642e6915bdcd860428a2cc10a9.tar.gz
add makedepends, backup, style
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 28 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8bf744eb305..da557dfd7a88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,15 @@
pkgbase = osmo-hlr-git
- pkgdesc = The Osmocom Home Location Register (OsmoHLR) is the subscriber database and authentication key store of an Osmocom 2G/3G network.
- pkgver = 1.0.0.5.g02078b7
+ pkgdesc = Subscriber database and authentication key store of an Osmocom 2G/3G network
+ pkgver = 1.0.0.6.gf9cf180
pkgrel = 1
url = https://osmocom.org/projects/osmo-hlr
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
license = GPL
+ makedepends = git
+ makedepends = talloc
depends = libosmocore
depends = libosmo-abis
depends = sqlite
@@ -12,7 +17,8 @@ pkgbase = osmo-hlr-git
depends = libdbi-drivers
provides = osmo-hlr
conflicts = osmo-hlr
- source = git://git.osmocom.org/osmo-hlr
+ backup = etc/osmocom/osmo-hlr.cfg
+ source = git+https://git.osmocom.org/osmo-hlr
sha256sums = SKIP
pkgname = osmo-hlr-git
diff --git a/PKGBUILD b/PKGBUILD
index c79f0ab11306..50f395e30285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
pkgname=osmo-hlr-git
-_pkgname=osmo-hlr
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-pkgver=1.0.0.5.g02078b7
+pkgver=1.0.0.6.gf9cf180
pkgrel=1
-pkgdesc="The Osmocom Home Location Register (OsmoHLR) is the subscriber database and authentication key store of an Osmocom 2G/3G network."
+pkgdesc="Subscriber database and authentication key store of an Osmocom 2G/3G network"
url="https://osmocom.org/projects/osmo-hlr"
-arch=('any')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
depends=('libosmocore' 'libosmo-abis' 'sqlite' 'libdbi' 'libdbi-drivers')
-source=("git://git.osmocom.org/${_pkgname}")
+makedepends=('git' 'talloc')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+backup=('etc/osmocom/osmo-hlr.cfg')
+source=("git+https://git.osmocom.org/${pkgname%-git}")
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
- echo $(git describe --always | sed 's/-/./g')
+ cd "${srcdir}/${pkgname%-git}"
+ echo $(git describe --always | sed 's/-/./g')
}
build() {
- cd "${srcdir}/${_pkgname}"
- autoreconf -i
- ./configure --prefix=/usr
- make
+ cd "${srcdir}/${pkgname%-git}"
+ autoreconf -i
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
}
package() {
- cd "${srcdir}/${_pkgname}"
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname%-git}"
+ make DESTDIR=${pkgdir} install
}
+
+# vim:set ts=2 sw=2 et: