summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-06 18:15:08 +0100
committerJosef Miegl2019-02-06 18:15:08 +0100
commit58bbd8d9b93cd3f11f35a0b2ccfc560a2eac8ecb (patch)
tree2f3b7f436bc97bf13013e44682d756dabb3dc565
downloadaur-58bbd8d9b93cd3f11f35a0b2ccfc560a2eac8ecb.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8bf744eb305
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = osmo-hlr-git
+ pkgdesc = The Osmocom Home Location Register (OsmoHLR) is the subscriber database and authentication key store of an Osmocom 2G/3G network.
+ pkgver = 1.0.0.5.g02078b7
+ pkgrel = 1
+ url = https://osmocom.org/projects/osmo-hlr
+ arch = any
+ license = GPL
+ depends = libosmocore
+ depends = libosmo-abis
+ depends = sqlite
+ depends = libdbi
+ depends = libdbi-drivers
+ provides = osmo-hlr
+ conflicts = osmo-hlr
+ source = git://git.osmocom.org/osmo-hlr
+ sha256sums = SKIP
+
+pkgname = osmo-hlr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c79f0ab11306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Josef Miegl <josef@miegl.cz>
+
+pkgname=osmo-hlr-git
+_pkgname=osmo-hlr
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+pkgver=1.0.0.5.g02078b7
+pkgrel=1
+pkgdesc="The Osmocom Home Location Register (OsmoHLR) is the subscriber database and authentication key store of an Osmocom 2G/3G network."
+url="https://osmocom.org/projects/osmo-hlr"
+arch=('any')
+license=(GPL)
+depends=('libosmocore' 'libosmo-abis' 'sqlite' 'libdbi' 'libdbi-drivers')
+source=("git://git.osmocom.org/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR=${pkgdir} install
+}