summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-13 20:27:43 +0100
committerJosef Miegl2019-02-13 20:27:43 +0100
commit70d3c95643112cd64aec0091016790830bd0e9df (patch)
tree833c1f484088ca3f1c0cc04e0a26fc5f6f960b2f
parent8a8dfc327258cd684eebdb3c8f8b43cc04a40eb4 (diff)
downloadaur-70d3c95643112cd64aec0091016790830bd0e9df.tar.gz
update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4c42c5de275..40bfb1961a3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osmo-mgw-git
pkgdesc = Media Gateway for handling user plane (voice) traffic in cellular networks
- pkgver = 1.5.0.2.ge36b775e
+ pkgver = 1.5.0.r2.ge36b775e
pkgrel = 1
url = https://osmocom.org/projects/osmo-mgw/
arch = i686
@@ -12,6 +12,7 @@ pkgbase = osmo-mgw-git
depends = libosmocore
depends = libosmo-abis
depends = libosmo-netif
+ depends = talloc
provides = osmo-mgw
conflicts = osmo-mgw
backup = etc/osmocom/osmo-mgw.cfg
diff --git a/PKGBUILD b/PKGBUILD
index 86bade97d81e..1e82e4a29afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
pkgname=osmo-mgw-git
-pkgver=1.5.0.2.ge36b775e
+pkgver=1.5.0.r2.ge36b775e
pkgrel=1
pkgdesc="Media Gateway for handling user plane (voice) traffic in cellular networks"
url="https://osmocom.org/projects/osmo-mgw/"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore' 'libosmo-abis' 'libosmo-netif')
+depends=('libosmocore' 'libosmo-abis' 'libosmo-netif' 'talloc')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -16,19 +16,23 @@ source=("git+https://git.osmocom.org/${pkgname%-git}")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
- echo $(git describe --always | sed 's/-/./g')
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ autoreconf -f -i
}
build() {
- cd "${srcdir}/${pkgname%-git}"
- autoreconf -i
- ./configure --prefix=/usr --sysconfdir=/etc
+ cd "${pkgname%-git}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
package() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${pkgname%-git}"
make DESTDIR=${pkgdir} install
}