summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-24 14:15:22 +0200
committeroli2015-06-24 14:15:22 +0200
commite4cbf24a2a37599c8b01ecf565cdfabb50ccfabb (patch)
tree6bd433ca2e39db3cb8e5e57401358b5508a7bd58
downloadaur-e4cbf24a2a37599c8b01ecf565cdfabb50ccfabb.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9090368de9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = osmupdate
+ pkgdesc = a tool to download and cumulate .osc OsmChange files of different categories (minutely, hourly, daily)
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = http://wiki.openstreetmap.org/wiki/Osmupdate
+ arch = i686
+ arch = x86_64
+ license = gpl
+ depends = glibc
+ source = http://m.m.i24.cc/osmupdate.c
+ md5sums = 740162c2400a5e8c78a1bd9a79993242
+
+pkgname = osmupdate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f9b3d2553b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jose Riha <jose1711 [at] gmail (dot) com>
+
+pkgname=osmupdate
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="a tool to download and cumulate .osc OsmChange files of different categories (minutely, hourly, daily)"
+arch=('i686' 'x86_64')
+url="http://wiki.openstreetmap.org/wiki/Osmupdate"
+license=("gpl")
+depends=('glibc')
+source=("http://m.m.i24.cc/osmupdate.c")
+md5sums=('740162c2400a5e8c78a1bd9a79993242')
+
+build() {
+cd $srcdir
+gcc -oosmupdate osmupdate.c
+}
+
+package() {
+install -Dm755 $srcdir/osmupdate $pkgdir/usr/bin/osmupdate
+}