summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCong Gu2016-11-28 16:37:37 -0600
committerCong Gu2016-11-28 16:37:37 -0600
commitf2ee80bdb16a6bdb47846ba8adf82c3d10179554 (patch)
treea19b79f8d38aa742372ad5fc1a5f282e24e88848
parent8fec9cc7fdc50b4cb62590a1d6001bed5c369986 (diff)
downloadaur-f2ee80bdb16a6bdb47846ba8adf82c3d10179554.tar.gz
dependency changed to embree-isa, use imagemagick
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--patch49
3 files changed, 15 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b65a960a6810..a85b11ac512b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Nov 15 04:25:17 UTC 2016
+# Mon Nov 28 22:36:35 UTC 2016
pkgbase = ospray
pkgdesc = A Ray Tracing Based Rendering Engine for High-Fidelity Visualization
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 3
url = http://www.ospray.org/
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = ospray
depends = qt4>=4.6
depends = ispc
depends = intel-tbb
- depends = embree
+ depends = embree-isa
+ depends = freeglut
+ depends = imagemagick
source = https://github.com/ospray/OSPRay/archive/v1.1.1.tar.gz
md5sums = 9185e6de4cf12faa971e2cc1f5757b81
diff --git a/PKGBUILD b/PKGBUILD
index 4ee95692c5b7..15273d3d98c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: <gucong43216@gmail.com>
+
pkgname=ospray
pkgver=1.1.1
-pkgrel=1
+pkgrel=3
pkgdesc="A Ray Tracing Based Rendering Engine for High-Fidelity Visualization"
arch=('i686' 'x86_64')
url="http://www.ospray.org/"
license=('Apache')
-depends=('qt4>=4.6' 'ispc' 'intel-tbb' 'embree')
+depends=('qt4>=4.6' 'ispc' 'intel-tbb' 'embree-isa' 'freeglut' 'imagemagick')
makedepends=('cmake')
-source=(https://github.com/ospray/OSPRay/archive/v$pkgver.tar.gz)
+source=("https://github.com/ospray/OSPRay/archive/v$pkgver.tar.gz")
md5sums=('9185e6de4cf12faa971e2cc1f5757b81')
+
prepare() {
cd "$srcdir"
@@ -23,11 +25,11 @@ build() {
export embree_DIR=/usr
- # EMBREE_MAX_ISA=AVX2 for Haswell and newer
- # https://en.wikipedia.org/wiki/Advanced_Vector_Extensions
+ # MAX_ISA is detected in package aur/embree-isa
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DOSPRAY_USE_EXTERNAL_EMBREE:BOOL=ON \
- -DEMBREE_MAX_ISA:STRING=AVX2 \
+ -DUSE_IMAGE_MAGICK:BOOL=ON \
../OSPRay-$pkgver
make
}
@@ -37,10 +39,8 @@ package() {
make DESTDIR="$pkgdir" install
- mv $pkgdir/usr/lib{64,}
-
- rm $pkgdir/usr/lib/libtbb*
- rm $pkgdir/usr/lib/libembree*
+ rm -f $pkgdir/usr/lib/libtbb*
+ rm -f $pkgdir/usr/lib/libembree*
}
# vim:set ts=2 sw=2 et:
diff --git a/patch b/patch
deleted file mode 100644
index 09abb3e4982c..000000000000
--- a/patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -ru OSPRay-1.0.0/apps/qtViewer/widgets/affineSpaceManipulator/QAffineSpaceManipulator.cpp src/OSPRay-1.0.0/apps/qtViewer/widgets/affineSpaceManipulator/QAffineSpaceManipulator.cpp
---- OSPRay-1.0.0/apps/qtViewer/widgets/affineSpaceManipulator/QAffineSpaceManipulator.cpp 2016-07-20 13:30:36.000000000 -0500
-+++ OSPRay-1.0.0/apps/qtViewer/widgets/affineSpaceManipulator/QAffineSpaceManipulator.cpp 2016-08-10 18:26:30.577820791 -0500
-@@ -375,7 +375,7 @@
- for (int y=0;y<Ny;y++) {
- const float t = (y+0.f)/Ny*2.f*M_PI;
- const float f = (x+0.f)/Nx*2.f*M_PI;
-- vtx[x][y] = vec3f(cos(t)*sin(f),sin(t)*sin(f),cos(f));
-+ vtx[x][y] = vec3f(ospcommon::cos(t)*ospcommon::sin(f),ospcommon::sin(t)*ospcommon::sin(f),ospcommon::cos(f));
- txt[x][y] = vec2f(x/float(Nx),y/float(Ny));
- vec3f c = (((x/4)+(y/4))%2) ? color_bright : color_dark;
- col[x][y] = vec3f(c);
-diff -ru OSPRay-1.0.0/ospray/lights/DirectionalLight.cpp src/OSPRay-1.0.0/ospray/lights/DirectionalLight.cpp
---- OSPRay-1.0.0/ospray/lights/DirectionalLight.cpp 2016-07-20 13:30:36.000000000 -0500
-+++ OSPRay-1.0.0/ospray/lights/DirectionalLight.cpp 2016-08-10 18:01:57.408643851 -0500
-@@ -38,7 +38,7 @@
- direction = -normalize(direction); // the ispc::DirLight expects direction towards light source
-
- angularDiameter = clamp(angularDiameter, 0.f, 180.f);
-- const float cosAngle = cos(deg2rad(0.5f*angularDiameter));
-+ const float cosAngle = ospcommon::cos(deg2rad(0.5f*angularDiameter));
-
- ispc::DirectionalLight_set(getIE(), (ispc::vec3f&)direction, (ispc::vec3f&)radiance, cosAngle);
- }
-diff -ru OSPRay-1.0.0/ospray/lights/SpotLight.cpp src/OSPRay-1.0.0/ospray/lights/SpotLight.cpp
---- OSPRay-1.0.0/ospray/lights/SpotLight.cpp 2016-07-20 13:30:36.000000000 -0500
-+++ OSPRay-1.0.0/ospray/lights/SpotLight.cpp 2016-08-10 18:03:40.671063737 -0500
-@@ -52,8 +52,8 @@
- direction = normalize(direction);
- openingAngle = clamp(openingAngle, 0.f, 180.f);
- penumbraAngle = clamp(penumbraAngle, 0.f, 0.5f*openingAngle);
-- const float cosAngleMax = cos(deg2rad(0.5f*openingAngle));
-- const float cosAngleMin = cos(deg2rad(0.5f*openingAngle - penumbraAngle));
-+ const float cosAngleMax = ospcommon::cos(deg2rad(0.5f*openingAngle));
-+ const float cosAngleMin = ospcommon::cos(deg2rad(0.5f*openingAngle - penumbraAngle));
- const float cosAngleScale = 1.0f/(cosAngleMin - cosAngleMax);
-
- ispc::SpotLight_set(getIE(),
---- OSPRay-1.0.0/cmake/FindTBB.cmake 2016-07-20 13:30:36.000000000 -0500
-+++ OSPRay-1.0.0/cmake/FindTBB.cmake 2016-09-25 23:22:28.673616827 -0500
-@@ -132,7 +132,7 @@
- IF (TBB_INCLUDE_DIR)
- FILE(READ ${TBB_INCLUDE_DIR}/tbb/tbb_stddef.h TBB_STDDEF_H)
-
-- STRING(REGEX MATCH "#define TBB_VERSION_MAJOR ([0-9])" DUMMY "${TBB_STDDEF_H}")
-+ STRING(REGEX MATCH "#define TBB_VERSION_MAJOR ([0-9]*)" DUMMY "${TBB_STDDEF_H}")
- SET(TBB_VERSION_MAJOR ${CMAKE_MATCH_1})
-
- STRING(REGEX MATCH "#define TBB_VERSION_MINOR ([0-9])" DUMMY "${TBB_STDDEF_H}")