summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-02-07 02:01:05 -0500
committerTony Lambiris2018-02-07 02:01:05 -0500
commit0c572b21525d495ebd4813c9582cf1482d9d7b5c (patch)
treeafb29a3686372c28f0cf41e8af681baa06cfed28
parente82cc7e50649b9c74e27a590c26a376d7d8966eb (diff)
downloadaur-0c572b21525d495ebd4813c9582cf1482d9d7b5c.tar.gz
Updates for osquery 3.0
-rw-r--r--PKGBUILD12
-rw-r--r--arch-linux.patch10
2 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 415f2d778090..b8c3f967c8a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.11.1.r0.g489ec3fc
+pkgver=3.0.0.r17.gbf2b4643
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -15,11 +15,11 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
'python-jinja' 'python-psutil' 'python-pexpect' 'rocksdb-lite'
'gtest' 'gmock' 'lldpd' 'lld' 'zstd' 'rapidjson' 'apt' 'dpkg'
'rpm-org' 'python2-jinja' 'librdkafka-git' 'augeas>=1.9.0'
- 'boost>=1.65.1' 'boost-libs>=1.65.1')
+ 'boost>=1.65.1' 'boost-libs>=1.65.1' 'libc++' 'cppcheck')
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit='b1f2888c8f101f1941a4377635e35f0b4ad9980e'
+_gitcommit='bf2b464301d96b0033a21978faaf3f41719ae04d'
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -28,7 +28,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec'
'0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4'
- '97b9f3b92f07797cc8027b4dcaef2ae9025d08367030364befe3a8895ededeb3')
+ 'bf524b6f0f65e6add6c265082315ac7df9461f7a8a2acfbc840e336794d12a78')
_gitname=${pkgname}
@@ -44,7 +44,7 @@ prepare() {
git reset HEAD --hard
git submodule update --init
- patch -p1 -F3 -i "${srcdir}/arch-linux.patch"
+ patch -p1 -i "${srcdir}/arch-linux.patch"
find . -type f -name '*apt_sources*' -delete
find . -type f -name '*deb_package*' -delete
@@ -64,6 +64,8 @@ build() {
#SQLITE_DEBUG=True # Enable SQLite query debugging (very verbose!)
#export SKIP_TESTS=True SKIP_BENCHMARKS=True
+ export CC=/usr/bin/gcc CXX=/usr/bin/g++
+
[[ -z $DEBUG ]] || unset DEBUG
cmake -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr \
diff --git a/arch-linux.patch b/arch-linux.patch
index 7ef4e7b31dd9..996944d1a036 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -25,13 +25,13 @@ index 3acf0c5..bd7612b 100644
implementation("system/windows/services@genServices")
examples([
diff --git a/Makefile b/Makefile
-index 2e2bd13c..c5ae915a 100644
+index 2ebc534f..98a0178d 100644
--- a/Makefile
+++ b/Makefile
-@@ -32,7 +32,7 @@ endif
- PATH_SET := PATH="$(DEPS_DIR)/bin:/usr/local/bin:$(PATH)"
- CMAKE := $(PATH_SET) CXXFLAGS="-L$(DEPS_DIR)/lib" cmake ../../
- CTEST := $(PATH_SET) ctest ../../
+@@ -70,7 +70,7 @@ CMAKE := $(PATH_SET) LDFLAGS="-L$(DEPS_DIR)/legacy/lib -L$(DEPS_DIR)/lib $(LINK_
+ cmake $(CMAKE_EXTRA) $(SOURCE_DIR)/
+
+ CTEST := $(PATH_SET) ctest $(SOURCE_DIR)/
-FORMAT_COMMAND := python tools/formatting/git-clang-format.py \
+FORMAT_COMMAND := python2 tools/formatting/git-clang-format.py \
"--commit" "master" "-f" "--style=file"