summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-08-20 12:51:34 -0400
committerTony Lambiris2017-08-20 12:51:34 -0400
commit2d66d9849d5401387151a63c953f8bf67b269aec (patch)
tree43ebae7159cb7cf7766fab7347e83bcd78209978
parentffd0b4e5aa1f2f4810fd035ef01b089f1e39df00 (diff)
downloadaur-2d66d9849d5401387151a63c953f8bf67b269aec.tar.gz
Add deps and bump version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--arch-linux.patch13
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62d0dc5473e1..a01fdf306fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -40,6 +40,8 @@ pkgbase = osquery-git
makedepends = boost-libs
makedepends = lldpd
makedepends = lld
+ makedepends = zstd
+ makedepends = rapidjson
makedepends = apt
makedepends = dpkg
makedepends = rpm-org
@@ -47,14 +49,14 @@ pkgbase = osquery-git
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=b4316a57a04a6efb6b56dc23593cae3c10ad7118
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=cf170c4278fe09301b4910fd9aae548fb0fc6799
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = 6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55
sha256sums = 9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b
- sha256sums = f993130c1612474a692ec2bf6f853d47b283c94a52e90d1036c8ac60ddd0d3df
+ sha256sums = 75c2c600752caf66bf5457d4bd08fba9c0b7e14918bf21ca8704640a5894bdcd
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index bd7b1725fd4d..398ea8cee8e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,11 +14,11 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
'sleuthkit' 'snappy' 'yara' 'thrift' 'magic' 'cpp-netlib'
'python-jinja' 'python-psutil' 'python-pexpect' 'rocksdb-lite'
'gtest' 'gmock' 'augeas' 'boost' 'boost-libs' 'lldpd' 'lld'
- 'apt' 'dpkg' 'rpm-org')
+ 'zstd' 'rapidjson' 'apt' 'dpkg' 'rpm-org')
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="b4316a57a04a6efb6b56dc23593cae3c10ad7118"
+_gitcommit="cf170c4278fe09301b4910fd9aae548fb0fc6799"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -27,7 +27,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55'
'9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b'
- 'f993130c1612474a692ec2bf6f853d47b283c94a52e90d1036c8ac60ddd0d3df')
+ '75c2c600752caf66bf5457d4bd08fba9c0b7e14918bf21ca8704640a5894bdcd')
_gitname=${pkgname}
diff --git a/arch-linux.patch b/arch-linux.patch
index 10cc8dd26ca9..f28d7a8a083c 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -85,3 +85,16 @@ index 4444a9a2..b9c2640d 100644
elseif(OSQUERY_BUILD_PLATFORM STREQUAL "debian")
LOG_PLATFORM("Debian")
elseif(OSQUERY_BUILD_PLATFORM STREQUAL "ubuntu")
+diff --git a/osquery/tables/CMakeLists.txt b/osquery/tables/CMakeLists.txt
+index 99477c69..d07730e2 100644
+--- a/osquery/tables/CMakeLists.txt
++++ b/osquery/tables/CMakeLists.txt
+@@ -67,7 +67,7 @@ if(LINUX)
+ set(TABLE_PLATFORM "linux")
+
+ ADD_OSQUERY_LINK_ADDITIONAL("libresolv.so")
+- ADD_OSQUERY_LINK_ADDITIONAL("cryptsetup devmapper lvm2app lvm-internal daemonclient")
++ ADD_OSQUERY_LINK_ADDITIONAL("cryptsetup devmapper lvm2app")
+ ADD_OSQUERY_LINK_ADDITIONAL("gcrypt gpg-error")
+ ADD_OSQUERY_LINK_ADDITIONAL("blkid")
+ ADD_OSQUERY_LINK_ADDITIONAL("ip4tc")