summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-04-10 15:42:09 -0400
committerTony Lambiris2017-04-10 15:42:09 -0400
commit6a3ad5119a9dbb86bd7bace1ed515d9f06d5fbc9 (patch)
tree517a76f7bace7332cda3a069dd55153f1596389c
parent1356ea5823dc6434e388a8e97dd72c171c202c66 (diff)
downloadaur-6a3ad5119a9dbb86bd7bace1ed515d9f06d5fbc9.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--arch-linux.patch13
3 files changed, 8 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0d5003aa0e9..9d9cd0784b81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.3.4.r49.g5bbff293
- pkgrel = 2
+ pkgver = 2.4.0.r2.g31b78cb9
+ pkgrel = 1
url = https://osquery.io
arch = i686
arch = x86_64
@@ -44,14 +44,14 @@ pkgbase = osquery-git
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=5bbff29387a090dce5a006584f41f66f52618ac2
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=31b78cb996c78c35a4a2ce759c99c49975e877e6
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = 3aea1799571f6ddab8d4c9820686fb64e7989e8121a98747a65326cd9f62f7e1
sha256sums = 7b1082c9a74e11b02fa6d8410e987db64be2e097f84fcd346e7feef8c1e8a104
- sha256sums = b47beb669c630ff2e564fdc1f87ddcf91e08badeece04f9f7907cb00a5675e23
+ sha256sums = 3494a662165f4862f3bc6c575ae11f36448ade01a2f316a03f95612de2d08163
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index 969b0da225ef..e523a4be0a53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.3.4.r49.g5bbff293
-pkgrel=2
+pkgver=2.4.0.r2.g31b78cb9
+pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
url="https://osquery.io"
@@ -16,7 +16,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
'augeas' 'boost' 'boost-libs' 'lldpd' 'apt' 'dpkg' 'rpm-org')
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="5bbff29387a090dce5a006584f41f66f52618ac2"
+_gitcommit="31b78cb996c78c35a4a2ce759c99c49975e877e6"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -25,7 +25,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'3aea1799571f6ddab8d4c9820686fb64e7989e8121a98747a65326cd9f62f7e1'
'7b1082c9a74e11b02fa6d8410e987db64be2e097f84fcd346e7feef8c1e8a104'
- 'b47beb669c630ff2e564fdc1f87ddcf91e08badeece04f9f7907cb00a5675e23')
+ '3494a662165f4862f3bc6c575ae11f36448ade01a2f316a03f95612de2d08163')
_gitname=${pkgname}
diff --git a/arch-linux.patch b/arch-linux.patch
index 7dd57f7a98a5..ca74540519fe 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -24,19 +24,6 @@ index 3acf0c5..bd7612b 100644
])
implementation("system/windows/services@genServices")
examples([
-diff --git a/osquery/extensions/CMakeLists.txt b/osquery/extensions/CMakeLists.txt
-index 5147c1a9..1c072e4c 100644
---- a/osquery/extensions/CMakeLists.txt
-+++ b/osquery/extensions/CMakeLists.txt
-@@ -1,7 +1,7 @@
- # Generate the thrift intermediate/interface code.
- add_custom_command(
- COMMAND
-- ${THRIFT_COMPILER} --gen cpp:dense --gen py:dense "${CMAKE_SOURCE_DIR}/osquery.thrift"
-+ ${THRIFT_COMPILER} --gen cpp --gen py "${CMAKE_SOURCE_DIR}/osquery.thrift"
- DEPENDS "${CMAKE_SOURCE_DIR}/osquery.thrift"
- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/generated"
- OUTPUT ${OSQUERY_THRIFT_GENERATED_FILES}
diff --git a/include/osquery/core.h b/include/osquery/core.h
index a367f913..c522d558 100644
--- a/include/osquery/core.h