summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-03-16 22:28:33 -0400
committerTony Lambiris2017-03-16 22:28:33 -0400
commit6ab4e3cc310b3a19de7da1e6c10126825a58b28c (patch)
treea14f59a461684459c40b9d278a8e8b0ada9e9664
parent3777d97581f81f0554ade7e22798be36c0124c94 (diff)
downloadaur-6ab4e3cc310b3a19de7da1e6c10126825a58b28c.tar.gz
Update osquery commit hash/patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--arch-linux.patch16
3 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f7db7f43198..c1984be67b28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.3.4.r12.gc8c5b7fa
+ pkgver = 2.3.4.r22.g3a5aca9c
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -44,14 +44,14 @@ pkgbase = osquery-git
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=c8c5b7fa223455f76116ade3338432a256035ee9
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=3a5aca9c946ba068c10aa613a7ada19155ef1fb3
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = 3aea1799571f6ddab8d4c9820686fb64e7989e8121a98747a65326cd9f62f7e1
sha256sums = 7b1082c9a74e11b02fa6d8410e987db64be2e097f84fcd346e7feef8c1e8a104
- sha256sums = 4d058c84ab14b6057a261b39709f8755bb28bb402ddd0c25c11aa993c11a9a60
+ sha256sums = b47beb669c630ff2e564fdc1f87ddcf91e08badeece04f9f7907cb00a5675e23
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index 0135230c8738..4e522b1c6cb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.3.4.r12.gc8c5b7fa
+pkgver=2.3.4.r22.g3a5aca9c
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
'augeas' 'boost' 'boost-libs' 'lldpd' 'apt' 'dpkg' 'rpm-org')
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="c8c5b7fa223455f76116ade3338432a256035ee9"
+_gitcommit="3a5aca9c946ba068c10aa613a7ada19155ef1fb3"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -25,7 +25,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'3aea1799571f6ddab8d4c9820686fb64e7989e8121a98747a65326cd9f62f7e1'
'7b1082c9a74e11b02fa6d8410e987db64be2e097f84fcd346e7feef8c1e8a104'
- '4d058c84ab14b6057a261b39709f8755bb28bb402ddd0c25c11aa993c11a9a60')
+ 'b47beb669c630ff2e564fdc1f87ddcf91e08badeece04f9f7907cb00a5675e23')
_gitname=${pkgname}
diff --git a/arch-linux.patch b/arch-linux.patch
index 7b9137b934b0..7dd57f7a98a5 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -73,27 +73,21 @@ index a367f913..c522d558 100644
+using RecursiveLock = MUTEX_IMPL::lock_guard<MUTEX_IMPL::recursive_mutex>;
}
diff --git a/osquery/CMakeLists.txt b/osquery/CMakeLists.txt
-index 4c8ac8ca..195450da 100644
+index db05af9c..0b5c2291 100644
--- a/osquery/CMakeLists.txt
+++ b/osquery/CMakeLists.txt
-@@ -55,7 +55,7 @@ if(WINDOWS)
- ADD_OSQUERY_LINK_CORE("ssleay32")
- ADD_OSQUERY_LINK_CORE("eay32")
- ADD_OSQUERY_LINK_CORE("zlibstatic")
--
-+
- # Enable control flow guard
- ADD_OSQUERY_LINK_CORE("-guard:cf")
- else()
-@@ -69,10 +69,11 @@ endif()
+@@ -70,12 +70,13 @@ endif()
if(APPLE OR LINUX)
ADD_OSQUERY_LINK_CORE("libdl")
- ADD_OSQUERY_LINK_CORE("boost_system-mt")
- ADD_OSQUERY_LINK_CORE("boost_filesystem-mt")
+- ADD_OSQUERY_LINK_CORE("boost_context-mt")
+ ADD_OSQUERY_LINK_CORE("boost_system")
+ ADD_OSQUERY_LINK_CORE("boost_filesystem")
+ ADD_OSQUERY_LINK_CORE("boost_thread")
++ ADD_OSQUERY_LINK_CORE("boost_context")
+
ADD_OSQUERY_LINK_ADDITIONAL("rocksdb_lite")
- ADD_OSQUERY_LINK_ADDITIONAL("boost_regex-mt")
+ ADD_OSQUERY_LINK_ADDITIONAL("boost_regex")