summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-10-14 03:27:23 -0400
committerTony Lambiris2017-10-14 03:27:23 -0400
commit73eca5f762347d662dedfbbcb7959a16ba73eb13 (patch)
tree54b81f98c737e29efe308d90f83da9a07b01f51b
parentac7e9c52cb58f1a2aee16ad2a37b04165f6a1c01 (diff)
downloadaur-73eca5f762347d662dedfbbcb7959a16ba73eb13.tar.gz
Version bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--arch-linux.patch26
3 files changed, 6 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 891e761db00d..07138a9547fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.9.0.r17.g70220308
+ pkgver = 2.9.0.r22.gd341d92c
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -50,14 +50,14 @@ pkgbase = osquery-git
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=702203086f88931e32a4a582edc79d4a33d44798
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=e888f3e8e893b8bb1207369abce3477539518659
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = 6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55
sha256sums = 9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b
- sha256sums = 9f9f04175e720ca93ec29d6401235d1625d7a0919b46b443201868ecf676760e
+ sha256sums = 450e87b9f38c55627ba13b8446e5be864286b31253511792b85f158e79a4a240
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index 4543ab61d340..4ad633f1b881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.9.0.r17.g70220308
+pkgver=2.9.0.r22.gd341d92c
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="702203086f88931e32a4a582edc79d4a33d44798"
+_gitcommit="e888f3e8e893b8bb1207369abce3477539518659"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -27,7 +27,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55'
'9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b'
- '9f9f04175e720ca93ec29d6401235d1625d7a0919b46b443201868ecf676760e')
+ '450e87b9f38c55627ba13b8446e5be864286b31253511792b85f158e79a4a240')
_gitname=${pkgname}
diff --git a/arch-linux.patch b/arch-linux.patch
index 9d279c0c4c0c..3905c2f2837f 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -101,29 +101,3 @@ index 8efb6202..7f9d64aa 100644
ADD_OSQUERY_LINK_ADDITIONAL("gcrypt gpg-error")
ADD_OSQUERY_LINK_ADDITIONAL("blkid")
ADD_OSQUERY_LINK_ADDITIONAL("ip4tc")
-diff --git a/osquery/tables/system/linux/tests/md_tables_tests.cpp b/osquery/tables/system/linux/tests/md_tables_tests.cpp
-index bfe71092..2415ae1f 100644
---- a/osquery/tables/system/linux/tests/md_tables_tests.cpp
-+++ b/osquery/tables/system/linux/tests/md_tables_tests.cpp
-@@ -72,7 +72,7 @@ void GetDrivesForArrayTestHarness(std::string arrayName,
- EXPECT_CALL(md, getArrayInfo(arrayDevPath, _))
- .WillOnce(DoAll(SetArgReferee<1>(arrayInfo), Return(true)));
-
-- Sequence::Sequence s1;
-+ Sequence s1;
- for (int i = 0; i < MD_SB_DISKS; i++) {
- mdu_disk_info_t diskInfo;
- diskInfo.number = i;
-diff --git a/osquery/devtools/shell.cpp b/osquery/devtools/shell.cpp
-index 84507f66..7811b9c8 100644
---- a/osquery/devtools/shell.cpp
-+++ b/osquery/devtools/shell.cpp
-@@ -1185,7 +1185,7 @@ inline void meta_show(struct callback_data* p) {
-
- {
- fprintf(p->out, "\nNon-default flags/options:\n");
-- auto results = osquery::SQL::SQL(
-+ auto results = osquery::SQL(
- "select * from osquery_flags where default_value <> value");
- for (const auto& flag : results.rows()) {
- fprintf(p->out,