summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-10-30 17:13:32 -0400
committerTony Lambiris2017-10-30 17:13:32 -0400
commit7a3a5a4f921c513a008ef80645f4ab9c473c7a23 (patch)
tree9318f2a5234c7d034715f407c3e35e45db856635
parentdc0b9fca8673018d1b40c0c72117a7ccc38d2019 (diff)
downloadaur-7a3a5a4f921c513a008ef80645f4ab9c473c7a23.tar.gz
Version bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--arch-linux.patch35
3 files changed, 9 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88da7bcc0ba2..67b57ed03077 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.9.1.r0.g54a8de8b
+ pkgver = 2.10.0.r8.ga7c2669b
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -46,18 +46,19 @@ pkgbase = osquery-git
makedepends = dpkg
makedepends = rpm-org
makedepends = python2-jinja
+ makedepends = librdkafka-git
depends = wget
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=54a8de8b6d8cb5c34a5e2a8b6d7e949018588bd8
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=a7c2669ba319534b618a01221889a64809290328
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = 6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55
sha256sums = 9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b
- sha256sums = 450e87b9f38c55627ba13b8446e5be864286b31253511792b85f158e79a4a240
+ sha256sums = 97b9f3b92f07797cc8027b4dcaef2ae9025d08367030364befe3a8895ededeb3
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index d9ef76f6ae8c..d82c619d9e11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.9.1.r0.g54a8de8b
+pkgver=2.10.0.r8.ga7c2669b
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -14,11 +14,12 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
'sleuthkit' 'snappy' 'yara' 'thrift' 'magic' 'cpp-netlib'
'python-jinja' 'python-psutil' 'python-pexpect' 'rocksdb-lite'
'gtest' 'gmock' 'augeas' 'boost' 'boost-libs' 'lldpd' 'lld'
- 'zstd' 'rapidjson' 'apt' 'dpkg' 'rpm-org' 'python2-jinja')
+ 'zstd' 'rapidjson' 'apt' 'dpkg' 'rpm-org' 'python2-jinja'
+ 'librdkafka-git')
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="54a8de8b6d8cb5c34a5e2a8b6d7e949018588bd8"
+_gitcommit="a7c2669ba319534b618a01221889a64809290328"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -27,7 +28,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55'
'9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b'
- '450e87b9f38c55627ba13b8446e5be864286b31253511792b85f158e79a4a240')
+ '97b9f3b92f07797cc8027b4dcaef2ae9025d08367030364befe3a8895ededeb3')
_gitname=${pkgname}
diff --git a/arch-linux.patch b/arch-linux.patch
index 3905c2f2837f..7ef4e7b31dd9 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -24,41 +24,6 @@ index 3acf0c5..bd7612b 100644
])
implementation("system/windows/services@genServices")
examples([
-diff --git a/include/osquery/core.h b/include/osquery/core.h
-index a367f913..c522d558 100644
---- a/include/osquery/core.h
-+++ b/include/osquery/core.h
-@@ -15,8 +15,9 @@
- #include <string>
- #include <vector>
-
--#if defined(__APPLE__) || defined(__FreeBSD__)
-+#if defined(__APPLE__) || defined(__FreeBSD__) || defined(__linux__)
- #include <boost/thread/shared_mutex.hpp>
-+#include <boost/thread/recursive_mutex.hpp>
- #else
- #include <shared_mutex>
- #endif
-@@ -182,7 +183,7 @@ inline bool isPlatform(PlatformType a, const PlatformType& t = kPlatformType) {
- return (static_cast<int>(t) & static_cast<int>(a)) != 0;
- }
-
--#if defined(__APPLE__) || defined(__FreeBSD__)
-+#if defined(__APPLE__) || defined(__FreeBSD__) || defined(__linux__)
- #define MUTEX_IMPL boost
- #else
- #define MUTEX_IMPL std
-@@ -198,8 +199,8 @@ using WriteLock = MUTEX_IMPL::unique_lock<Mutex>;
- using ReadLock = MUTEX_IMPL::shared_lock<Mutex>;
-
- /// Helper alias for defining recursive mutexes.
--using RecursiveMutex = std::recursive_mutex;
-+using RecursiveMutex = MUTEX_IMPL::recursive_mutex;
-
- /// Helper alias for write locking a recursive mutex.
--using RecursiveLock = std::lock_guard<std::recursive_mutex>;
-+using RecursiveLock = MUTEX_IMPL::lock_guard<MUTEX_IMPL::recursive_mutex>;
- }
diff --git a/Makefile b/Makefile
index 2e2bd13c..c5ae915a 100644
--- a/Makefile