summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-03-19 23:35:59 -0400
committerTony Lambiris2018-03-19 23:35:59 -0400
commita226be86df45e9d2d30878e069084eddf2540e38 (patch)
tree9a888703279b18fe8500d5e7ad2ee403eca6b211
parentf0bebba8c6241d0be5c328a64111aff1896d73be (diff)
downloadaur-a226be86df45e9d2d30878e069084eddf2540e38.tar.gz
Update osquery version, should compile again
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d3e98d294e1..bc3a1ec298da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 3.1.0.r42.g26bd3268
+ pkgver = 3.1.0.r50.g06117da0
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -53,7 +53,7 @@ pkgbase = osquery-git
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=26bd32687a1abbad9cb21b762bc33f9ea184d26e
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=06117da0f1407214fa59cc3afeff834193c8e0de
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
diff --git a/PKGBUILD b/PKGBUILD
index 37fbf7b703d6..0962a85c5f63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=3.1.0.r42.g26bd3268
+pkgver=3.1.0.r50.g06117da0
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -19,7 +19,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit='26bd32687a1abbad9cb21b762bc33f9ea184d26e'
+_gitcommit='06117da0f1407214fa59cc3afeff834193c8e0de'
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -42,7 +42,7 @@ prepare() {
git reset HEAD --hard
git submodule update --init
- patch -p1 -i "${srcdir}/arch-linux.patch"
+ patch -F3 -p1 -i "${srcdir}/arch-linux.patch"
find . -type f -name '*apt_sources*' -delete
find . -type f -name '*deb_package*' -delete
@@ -62,7 +62,7 @@ build() {
#SQLITE_DEBUG=True # Enable SQLite query debugging (very verbose!)
#export SKIP_TESTS=True SKIP_BENCHMARKS=True
- export CC=/usr/bin/gcc CXX=/usr/bin/g++ USE_RTTI=1
+ export CC=/usr/bin/gcc CXX=/usr/bin/g++
[[ -z $DEBUG ]] || unset DEBUG
cmake -Wno-dev \