summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-10-13 14:10:44 -0400
committerTony Lambiris2017-10-13 14:10:44 -0400
commitac7e9c52cb58f1a2aee16ad2a37b04165f6a1c01 (patch)
treecc0e0ccd21552333feded63a8bc456b6ab7ca465
parent6a95300ef22e113d030e224ac9d3c008cceedcd2 (diff)
downloadaur-ac7e9c52cb58f1a2aee16ad2a37b04165f6a1c01.tar.gz
Version bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--arch-linux.patch33
3 files changed, 38 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 917755d7a07a..891e761db00d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.7.0.r14.ge748f38a
+ pkgver = 2.9.0.r17.g70220308
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -50,14 +50,14 @@ pkgbase = osquery-git
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=4d631edac61c057857b595ea28352502151f5b3c
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=702203086f88931e32a4a582edc79d4a33d44798
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = 6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55
sha256sums = 9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b
- sha256sums = 75c2c600752caf66bf5457d4bd08fba9c0b7e14918bf21ca8704640a5894bdcd
+ sha256sums = 9f9f04175e720ca93ec29d6401235d1625d7a0919b46b443201868ecf676760e
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index 14f646a0f2f2..4543ab61d340 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.7.0.r14.ge748f38a
+pkgver=2.9.0.r17.g70220308
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="4d631edac61c057857b595ea28352502151f5b3c"
+_gitcommit="702203086f88931e32a4a582edc79d4a33d44798"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -27,7 +27,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55'
'9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b'
- '75c2c600752caf66bf5457d4bd08fba9c0b7e14918bf21ca8704640a5894bdcd')
+ '9f9f04175e720ca93ec29d6401235d1625d7a0919b46b443201868ecf676760e')
_gitname=${pkgname}
@@ -71,7 +71,7 @@ build() {
-DBUILD_GMOCK=OFF \
-DCMAKE_VERBOSE_MAKEFILE=ON
- find . -type f -name link.txt -exec sed -i -re 's/Bstatic -lgflags/Bdynamic -lgflags/g' "{}" \;
+ find . -type f -name link.txt -exec sed -i -re 's/Bstatic -lgflags/Bdynamic -lgflags/g' "{}" \;
make ${MAKEFLAGS} all
}
diff --git a/arch-linux.patch b/arch-linux.patch
index f28d7a8a083c..9d279c0c4c0c 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -86,15 +86,44 @@ index 4444a9a2..b9c2640d 100644
LOG_PLATFORM("Debian")
elseif(OSQUERY_BUILD_PLATFORM STREQUAL "ubuntu")
diff --git a/osquery/tables/CMakeLists.txt b/osquery/tables/CMakeLists.txt
-index 99477c69..d07730e2 100644
+index 8efb6202..7f9d64aa 100644
--- a/osquery/tables/CMakeLists.txt
+++ b/osquery/tables/CMakeLists.txt
-@@ -67,7 +67,7 @@ if(LINUX)
+@@ -66,8 +66,10 @@ endif()
+ if(LINUX)
set(TABLE_PLATFORM "linux")
++ include_directories("/usr/include/libxml2")
++
ADD_OSQUERY_LINK_ADDITIONAL("libresolv.so")
- ADD_OSQUERY_LINK_ADDITIONAL("cryptsetup devmapper lvm2app lvm-internal daemonclient")
+ ADD_OSQUERY_LINK_ADDITIONAL("cryptsetup devmapper lvm2app")
ADD_OSQUERY_LINK_ADDITIONAL("gcrypt gpg-error")
ADD_OSQUERY_LINK_ADDITIONAL("blkid")
ADD_OSQUERY_LINK_ADDITIONAL("ip4tc")
+diff --git a/osquery/tables/system/linux/tests/md_tables_tests.cpp b/osquery/tables/system/linux/tests/md_tables_tests.cpp
+index bfe71092..2415ae1f 100644
+--- a/osquery/tables/system/linux/tests/md_tables_tests.cpp
++++ b/osquery/tables/system/linux/tests/md_tables_tests.cpp
+@@ -72,7 +72,7 @@ void GetDrivesForArrayTestHarness(std::string arrayName,
+ EXPECT_CALL(md, getArrayInfo(arrayDevPath, _))
+ .WillOnce(DoAll(SetArgReferee<1>(arrayInfo), Return(true)));
+
+- Sequence::Sequence s1;
++ Sequence s1;
+ for (int i = 0; i < MD_SB_DISKS; i++) {
+ mdu_disk_info_t diskInfo;
+ diskInfo.number = i;
+diff --git a/osquery/devtools/shell.cpp b/osquery/devtools/shell.cpp
+index 84507f66..7811b9c8 100644
+--- a/osquery/devtools/shell.cpp
++++ b/osquery/devtools/shell.cpp
+@@ -1185,7 +1185,7 @@ inline void meta_show(struct callback_data* p) {
+
+ {
+ fprintf(p->out, "\nNon-default flags/options:\n");
+- auto results = osquery::SQL::SQL(
++ auto results = osquery::SQL(
+ "select * from osquery_flags where default_value <> value");
+ for (const auto& flag : results.rows()) {
+ fprintf(p->out,