summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-03-31 04:14:49 -0400
committerTony Lambiris2017-03-31 04:14:49 -0400
commitd5a5dd9726048910bc3c4f84025edd6871be324d (patch)
treeb525f40f18061f1645cb4a60b51e1e8c7a2d807e
parent286edc8542c07518cccafa3b29e326688eca2ff1 (diff)
downloadaur-d5a5dd9726048910bc3c4f84025edd6871be324d.tar.gz
Version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21bd96d8e5a3..f7622a8de8fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.3.4.r35.g198ee7ab
+ pkgver = 2.3.4.r49.g5bbff293
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -44,7 +44,7 @@ pkgbase = osquery-git
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=198ee7ab895cb210884cc9af46e9d1817debc402
+ source = osquery-git::git+https://github.com/facebook/osquery
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
diff --git a/PKGBUILD b/PKGBUILD
index 4378f44ab457..791422ff88ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.3.4.r35.g198ee7ab
+pkgver=2.3.4.r49.g5bbff293
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -17,8 +17,8 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
backup=('etc/osquery/osquery.conf')
options=(!strip)
_gitcommit="198ee7ab895cb210884cc9af46e9d1817debc402"
-#source=("${pkgname}::git+https://github.com/facebook/osquery"
-source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
+#source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
+source=("${pkgname}::git+https://github.com/facebook/osquery"
"osqueryd.conf.d"
"osqueryd.service"
"arch-linux.patch")
@@ -29,11 +29,11 @@ sha256sums=('SKIP'
_gitname=${pkgname}
-#pkgver() {
-# cd $_gitname
-#
-# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-#}
+pkgver() {
+ cd $_gitname
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
cd $_gitname