summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-11-19 18:21:28 -0500
committerTony Lambiris2017-11-19 18:21:28 -0500
commitdaa470b683e4b448680cfed01da7bbfe01b40d72 (patch)
tree46351fd4225429ccdeacadb8cc5ee89f825a61bb
parent9a1e37e791f75fbd3bba261e87f20180dc690a38 (diff)
downloadaur-daa470b683e4b448680cfed01da7bbfe01b40d72.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--osqueryd.conf.d2
-rw-r--r--osqueryd.service2
4 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 314cd0b9c540..99d8deedc8cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.10.2.r0.gc3a2171e
+ pkgver = 2.10.2.r14.g16d92d1d
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -51,13 +51,13 @@ pkgbase = osquery-git
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=c3a2171ebcc92fb3bbe3b94b8ab83916cd1ca275
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=16d92d1dc662f9dfd18186c9c58ab03f5d1a148e
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
- sha256sums = 6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55
- sha256sums = 9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b
+ sha256sums = ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec
+ sha256sums = 0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4
sha256sums = 97b9f3b92f07797cc8027b4dcaef2ae9025d08367030364befe3a8895ededeb3
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index 121beb2e04bc..de0f29ee62c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.10.2.r0.gc3a2171e
+pkgver=2.10.2.r14.g16d92d1d
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -19,15 +19,15 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="c3a2171ebcc92fb3bbe3b94b8ab83916cd1ca275"
+_gitcommit="16d92d1dc662f9dfd18186c9c58ab03f5d1a148e"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
"osqueryd.service"
"arch-linux.patch")
sha256sums=('SKIP'
- '6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55'
- '9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b'
+ 'ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec'
+ '0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4'
'97b9f3b92f07797cc8027b4dcaef2ae9025d08367030364befe3a8895ededeb3')
_gitname=${pkgname}
diff --git a/osqueryd.conf.d b/osqueryd.conf.d
index e647ec9b17d8..aff32487f983 100644
--- a/osqueryd.conf.d
+++ b/osqueryd.conf.d
@@ -1,4 +1,4 @@
FLAG_FILE="/etc/osquery/osquery.flags"
CONFIG_FILE="/etc/osquery/osquery.conf"
-OLD_PIDFILE="/var/osquery/osqueryd.pidfile"
+LOCAL_PIDFILE="/var/osquery/osqueryd.pidfile"
PIDFILE="/var/run/osqueryd.pidfile"
diff --git a/osqueryd.service b/osqueryd.service
index 4c4cbeaba791..0774bee73a2f 100644
--- a/osqueryd.service
+++ b/osqueryd.service
@@ -6,7 +6,7 @@ After=network.service syslog.service
TimeoutStartSec=0
EnvironmentFile=/etc/conf.d/osqueryd
ExecStartPre=/bin/sh -c "if [ ! -f $FLAG_FILE ]; then touch $FLAG_FILE; fi"
-ExecStartPre=/bin/sh -c "if [ -f $OLD_PIDFILE ]; then mv $OLD_PIDFILE $PIDFILE; fi"
+ExecStartPre=/bin/sh -c "if [ -f $LOCAL_PIDFILE ]; then mv $LOCAL_PIDFILE $PIDFILE; fi"
ExecStart=/usr/bin/osqueryd \
--flagfile $FLAG_FILE \
--config_path $CONFIG_FILE