summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-03-06 19:06:44 -0500
committerTony Lambiris2018-03-06 19:06:44 -0500
commitf0bebba8c6241d0be5c328a64111aff1896d73be (patch)
treea83b78244f7a53d8fc3ecc4aa33e16db0f804c4e
parent0c572b21525d495ebd4813c9582cf1482d9d7b5c (diff)
downloadaur-f0bebba8c6241d0be5c328a64111aff1896d73be.tar.gz
Version bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--arch-linux.patch8
-rw-r--r--osqueryd.service1
4 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3eefaa1aad7e..4d3e98d294e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.11.1.r0.g489ec3fc
+ pkgver = 3.1.0.r42.g26bd3268
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -47,18 +47,20 @@ pkgbase = osquery-git
makedepends = augeas>=1.9.0
makedepends = boost>=1.65.1
makedepends = boost-libs>=1.65.1
+ makedepends = libc++
+ makedepends = cppcheck
depends = wget
depends = unzip
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=b1f2888c8f101f1941a4377635e35f0b4ad9980e
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=26bd32687a1abbad9cb21b762bc33f9ea184d26e
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec
- sha256sums = 0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4
- sha256sums = 97b9f3b92f07797cc8027b4dcaef2ae9025d08367030364befe3a8895ededeb3
+ sha256sums = 82611f3296d1d5b68d2cb32200c95a9ae3469dc5a9696643b69e89a5b9798a72
+ sha256sums = c2d4b7e5e85cef135af82ca627f0c05e40ef5e2ffb9e128f01caacd8665c6c15
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index b8c3f967c8a7..37fbf7b703d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=3.0.0.r17.gbf2b4643
+pkgver=3.1.0.r42.g26bd3268
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -19,7 +19,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit='bf2b464301d96b0033a21978faaf3f41719ae04d'
+_gitcommit='26bd32687a1abbad9cb21b762bc33f9ea184d26e'
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -27,19 +27,17 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
"arch-linux.patch")
sha256sums=('SKIP'
'ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec'
- '0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4'
- 'bf524b6f0f65e6add6c265082315ac7df9461f7a8a2acfbc840e336794d12a78')
-
-_gitname=${pkgname}
+ '82611f3296d1d5b68d2cb32200c95a9ae3469dc5a9696643b69e89a5b9798a72'
+ 'c2d4b7e5e85cef135af82ca627f0c05e40ef5e2ffb9e128f01caacd8665c6c15')
#pkgver() {
-# cd $_gitname
+# cd ${pkgname}
#
# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
#}
prepare() {
- cd $_gitname
+ cd ${pkgname}
git reset HEAD --hard
git submodule update --init
@@ -54,7 +52,7 @@ prepare() {
}
build() {
- cd $_gitname
+ cd ${pkgname}
#SANITIZE_THREAD=True # Add -fsanitize=thread when using "make sanitize"
#OPTIMIZED=True # Enable specific CPU optimizations (not recommended)
@@ -64,7 +62,7 @@ build() {
#SQLITE_DEBUG=True # Enable SQLite query debugging (very verbose!)
#export SKIP_TESTS=True SKIP_BENCHMARKS=True
- export CC=/usr/bin/gcc CXX=/usr/bin/g++
+ export CC=/usr/bin/gcc CXX=/usr/bin/g++ USE_RTTI=1
[[ -z $DEBUG ]] || unset DEBUG
cmake -Wno-dev \
@@ -80,7 +78,7 @@ build() {
}
package() {
- cd $_gitname
+ cd ${pkgname}
make DESTDIR="${pkgdir}" install
diff --git a/arch-linux.patch b/arch-linux.patch
index 996944d1a036..935bcf1c9b3f 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -25,17 +25,17 @@ index 3acf0c5..bd7612b 100644
implementation("system/windows/services@genServices")
examples([
diff --git a/Makefile b/Makefile
-index 2ebc534f..98a0178d 100644
+index 47ff957d..ab679b5f 100644
--- a/Makefile
+++ b/Makefile
@@ -70,7 +70,7 @@ CMAKE := $(PATH_SET) LDFLAGS="-L$(DEPS_DIR)/legacy/lib -L$(DEPS_DIR)/lib $(LINK_
cmake $(CMAKE_EXTRA) $(SOURCE_DIR)/
-
+
CTEST := $(PATH_SET) ctest $(SOURCE_DIR)/
-FORMAT_COMMAND := python tools/formatting/git-clang-format.py \
+FORMAT_COMMAND := python2 tools/formatting/git-clang-format.py \
- "--commit" "master" "-f" "--style=file"
-
+ "--commit" "master" "-f" "--style=file"
+
ANALYSIS := ${SOURCE_DIR}/tools/analysis
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4444a9a2..b9c2640d 100644
diff --git a/osqueryd.service b/osqueryd.service
index 0774bee73a2f..75d04e322098 100644
--- a/osqueryd.service
+++ b/osqueryd.service
@@ -9,6 +9,7 @@ ExecStartPre=/bin/sh -c "if [ ! -f $FLAG_FILE ]; then touch $FLAG_FILE; fi"
ExecStartPre=/bin/sh -c "if [ -f $LOCAL_PIDFILE ]; then mv $LOCAL_PIDFILE $PIDFILE; fi"
ExecStart=/usr/bin/osqueryd \
--flagfile $FLAG_FILE \
+ --logger_min_stderr 1 \
--config_path $CONFIG_FILE
Restart=on-failure
KillMode=process