summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-06-22 01:31:51 -0400
committerTony Lambiris2017-06-22 01:31:51 -0400
commitf9c839133205af649477f35c2e9211ee8f11acfb (patch)
tree25bd2c788ad8cea2e0ba9f25dfc585093bba1987
parentaa745127eee236b1da797052cd828fa1ded254a3 (diff)
downloadaur-f9c839133205af649477f35c2e9211ee8f11acfb.tar.gz
Version bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--arch-linux.patch22
3 files changed, 6 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef07941a360c..69403100c0e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.5.0.r0.g445fc126
+ pkgver = 2.5.1.r7.g256d113a
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -47,14 +47,14 @@ pkgbase = osquery-git
conflicts = gmock
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=445fc126482a1fa2bfb206defe45dac84bce48b0
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=256d113a74448ecfb0af024c0fdd1d8f1c54fec5
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = 3aea1799571f6ddab8d4c9820686fb64e7989e8121a98747a65326cd9f62f7e1
sha256sums = 7b1082c9a74e11b02fa6d8410e987db64be2e097f84fcd346e7feef8c1e8a104
- sha256sums = e0dd9964a1754b28f2be014ee617cd99be13b1a6a14e025b3b2104f70e424fd8
+ sha256sums = f993130c1612474a692ec2bf6f853d47b283c94a52e90d1036c8ac60ddd0d3df
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index a7b143de4acd..d9fcc40acf2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.5.0.r0.g445fc126
+pkgver=2.5.1.r7.g256d113a
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -17,7 +17,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
conflicts=('gtest' 'gmock')
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="445fc126482a1fa2bfb206defe45dac84bce48b0"
+_gitcommit="256d113a74448ecfb0af024c0fdd1d8f1c54fec5"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -26,7 +26,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'3aea1799571f6ddab8d4c9820686fb64e7989e8121a98747a65326cd9f62f7e1'
'7b1082c9a74e11b02fa6d8410e987db64be2e097f84fcd346e7feef8c1e8a104'
- 'e0dd9964a1754b28f2be014ee617cd99be13b1a6a14e025b3b2104f70e424fd8')
+ 'f993130c1612474a692ec2bf6f853d47b283c94a52e90d1036c8ac60ddd0d3df')
_gitname=${pkgname}
diff --git a/arch-linux.patch b/arch-linux.patch
index c226b0477930..10cc8dd26ca9 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -59,28 +59,6 @@ index a367f913..c522d558 100644
-using RecursiveLock = std::lock_guard<std::recursive_mutex>;
+using RecursiveLock = MUTEX_IMPL::lock_guard<MUTEX_IMPL::recursive_mutex>;
}
-diff --git a/osquery/CMakeLists.txt b/osquery/CMakeLists.txt
-index db05af9c..0b5c2291 100644
---- a/osquery/CMakeLists.txt
-+++ b/osquery/CMakeLists.txt
-@@ -70,12 +70,13 @@ endif()
-
- if(APPLE OR LINUX)
- ADD_OSQUERY_LINK_CORE("libdl")
-- ADD_OSQUERY_LINK_CORE("boost_system-mt")
-- ADD_OSQUERY_LINK_CORE("boost_filesystem-mt")
-- ADD_OSQUERY_LINK_CORE("boost_context-mt")
-+ ADD_OSQUERY_LINK_CORE("boost_system")
-+ ADD_OSQUERY_LINK_CORE("boost_filesystem")
-+ ADD_OSQUERY_LINK_CORE("boost_thread")
-+ ADD_OSQUERY_LINK_CORE("boost_context")
-
- ADD_OSQUERY_LINK_ADDITIONAL("rocksdb_lite")
-- ADD_OSQUERY_LINK_ADDITIONAL("boost_regex-mt")
-+ ADD_OSQUERY_LINK_ADDITIONAL("boost_regex")
- elseif(FREEBSD)
- ADD_OSQUERY_LINK_CORE("icuuc")
- ADD_OSQUERY_LINK_CORE("boost_system")
diff --git a/Makefile b/Makefile
index 2e2bd13c..c5ae915a 100644
--- a/Makefile