summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-08-07 18:05:38 -0400
committerTony Lambiris2017-08-07 18:05:38 -0400
commitffd0b4e5aa1f2f4810fd035ef01b089f1e39df00 (patch)
treeeb4ce1929875dff0dc71fd34a312cfa5c0a85e63
parent6d13189294cf97d7e0231ddc6fd4bca3dd56f0cf (diff)
downloadaur-ffd0b4e5aa1f2f4810fd035ef01b089f1e39df00.tar.gz
Version bump, sync files with upstream
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--osqueryd.conf.d2
-rw-r--r--osqueryd.service1
4 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 783cfb921c50..62d0dc5473e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 2.5.2.r4.ga36d6342
+ pkgver = 2.6.1.r6.gb4316a57
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -33,6 +33,8 @@ pkgbase = osquery-git
makedepends = python-psutil
makedepends = python-pexpect
makedepends = rocksdb-lite
+ makedepends = gtest
+ makedepends = gmock
makedepends = augeas
makedepends = boost
makedepends = boost-libs
@@ -43,17 +45,15 @@ pkgbase = osquery-git
makedepends = rpm-org
depends = wget
depends = unzip
- conflicts = gtest
- conflicts = gmock
options = !strip
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=e17584f44f86b14ee6638ddb23a3a38fa7a0c7e7
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=b4316a57a04a6efb6b56dc23593cae3c10ad7118
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
- sha256sums = 3aea1799571f6ddab8d4c9820686fb64e7989e8121a98747a65326cd9f62f7e1
- sha256sums = 7b1082c9a74e11b02fa6d8410e987db64be2e097f84fcd346e7feef8c1e8a104
+ sha256sums = 6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55
+ sha256sums = 9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b
sha256sums = f993130c1612474a692ec2bf6f853d47b283c94a52e90d1036c8ac60ddd0d3df
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index 794026fadf78..bd7b1725fd4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=2.5.2.r4.ga36d6342
+pkgver=2.6.1.r6.gb4316a57
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -13,19 +13,20 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
'llvm' 'lsb-release' 'beecrypt' 'python-jinja' 'python-pip'
'sleuthkit' 'snappy' 'yara' 'thrift' 'magic' 'cpp-netlib'
'python-jinja' 'python-psutil' 'python-pexpect' 'rocksdb-lite'
- 'augeas' 'boost' 'boost-libs' 'lldpd' 'lld' 'apt' 'dpkg' 'rpm-org')
-conflicts=('gtest' 'gmock')
+ 'gtest' 'gmock' 'augeas' 'boost' 'boost-libs' 'lldpd' 'lld'
+ 'apt' 'dpkg' 'rpm-org')
+conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip)
-_gitcommit="e17584f44f86b14ee6638ddb23a3a38fa7a0c7e7"
+_gitcommit="b4316a57a04a6efb6b56dc23593cae3c10ad7118"
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
"osqueryd.service"
"arch-linux.patch")
sha256sums=('SKIP'
- '3aea1799571f6ddab8d4c9820686fb64e7989e8121a98747a65326cd9f62f7e1'
- '7b1082c9a74e11b02fa6d8410e987db64be2e097f84fcd346e7feef8c1e8a104'
+ '6a5522f9058fc3d142dd3642f73ccd2758cc0b43bd28644a0f4eee3e5d7aea55'
+ '9fcfe9db909c664f7dfeeb7c56c9d964eb6d7673dbe5a4858c09a3953f13cd4b'
'f993130c1612474a692ec2bf6f853d47b283c94a52e90d1036c8ac60ddd0d3df')
_gitname=${pkgname}
@@ -66,6 +67,7 @@ build() {
cmake -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_CXX_FLAGS="-I/usr/include/libxml2" \
+ -DBUILD_GMOCK=OFF \
-DCMAKE_VERBOSE_MAKEFILE=ON
find . -type f -name link.txt -exec sed -i -re 's/Bstatic -lgflags/Bdynamic -lgflags/g' "{}" \;
diff --git a/osqueryd.conf.d b/osqueryd.conf.d
index 45f7dfdefba9..e647ec9b17d8 100644
--- a/osqueryd.conf.d
+++ b/osqueryd.conf.d
@@ -1,2 +1,4 @@
FLAG_FILE="/etc/osquery/osquery.flags"
CONFIG_FILE="/etc/osquery/osquery.conf"
+OLD_PIDFILE="/var/osquery/osqueryd.pidfile"
+PIDFILE="/var/run/osqueryd.pidfile"
diff --git a/osqueryd.service b/osqueryd.service
index 5258f6d199c1..4c4cbeaba791 100644
--- a/osqueryd.service
+++ b/osqueryd.service
@@ -6,6 +6,7 @@ After=network.service syslog.service
TimeoutStartSec=0
EnvironmentFile=/etc/conf.d/osqueryd
ExecStartPre=/bin/sh -c "if [ ! -f $FLAG_FILE ]; then touch $FLAG_FILE; fi"
+ExecStartPre=/bin/sh -c "if [ -f $OLD_PIDFILE ]; then mv $OLD_PIDFILE $PIDFILE; fi"
ExecStart=/usr/bin/osqueryd \
--flagfile $FLAG_FILE \
--config_path $CONFIG_FILE