aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuuki Galaxy2018-08-29 17:25:53 +0800
committerYuuki Galaxy2018-08-29 17:25:53 +0800
commitc31e5fd4ad7db9a4cab0ea0119762862cadb81c8 (patch)
treee390c70c8414d470e4f667193cc83d4ac04b8850
parent16eb4f4941b7163d2fb1d5b91244b7061de9037f (diff)
downloadaur-c31e5fd4ad7db9a4cab0ea0119762862cadb81c8.tar.gz
Fix Compile error on ossdetect with glibc 2.23
-rw-r--r--PKGBUILD9
-rw-r--r--README.md8
-rw-r--r--oss4_sys-libs_glibc-2.23_ossdetect_fix_git.patch18
3 files changed, 33 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46b3c4ba2222..f4344be2afd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,13 +10,14 @@
pkgbase=oss-git
pkgname=oss-git
true && pkgname=(oss-git libflashsupport-oss-git)
-pkgver=891ddd2
-pkgrel=7
+pkgver=7cf6b07
+pkgrel=1
arch=(i686 x86_64)
url="http://developer.opensound.com/"
license=(GPL2)
makedepends=(gtk2 git)
source=(oss::git://git.code.sourceforge.net/p/opensound/git
+ oss4_sys-libs_glibc-2.23_ossdetect_fix_git.patch
oss.service
remove-hal.patch
rm-init-scripts.patch
@@ -24,6 +25,7 @@ source=(oss::git://git.code.sourceforge.net/p/opensound/git
kmod-link.patch
ossvermagic.patch)
sha512sums=('SKIP'
+ '5599f75ac2784aca7d0367e88705938d2680e7a0eb7ae7300080e3fc0ea0c9d3b183554a9e208ed8359f675028024e8de62baa5f8dbc79e9f3bd942db6aa6157'
'355e1380432947c0e9caa21114b2c3debeb162fb5abcf845125ec281ce52b437ad1ee1db04d37e9b7a5ac79816c4dcbc21b4ed4cf8191f71218d99acd7bab70e'
'6956e5e2e9323b568bb18e80bbee591b0e5ffd3d4612a50df09879941b2733c31d6b3178dc9a46c283bd1629f76b7ff5e2b54893a42a47f6379eaee4731fd9be'
'64e6d9d8eb5320f737d3a0698a245da2b2d141b68cfb2f02e448144d1c610aa8b8a6c38b56fcca364d63171a49afe93161a00545cdb90086b5328997b3096690'
@@ -54,6 +56,9 @@ prepare() {
# patch -p0 < "$srcdir/linux-4.8-usercopy.patch"
patch -p0 < "$srcdir/ossvermagic.patch"
+ # make OSS compile with glibc >= 2.23
+ patch -p1 < "$srcdir/oss4_sys-libs_glibc-2.23_ossdetect_fix_git.patch"
+
# make OSS compile with gcc-5
# - no longer required (from commit b3dc64)
# patch -p0 < "$srcdir/gcc-5.patch"
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..c041ae091025
--- /dev/null
+++ b/README.md
@@ -0,0 +1,8 @@
+# oss-git
+
+Original Source: <https://aur.archlinux.org/packages/oss-git>.
+
+Fix Compile error with ossdetect with glibc starting with version 2.23 accroding to <http://ossnext.trueinstruments.com/forum/viewtopic.php?t=5855>.
+
+See also: <https://forums.gentoo.org/viewtopic-t-1039602-start-0.html>.
+
diff --git a/oss4_sys-libs_glibc-2.23_ossdetect_fix_git.patch b/oss4_sys-libs_glibc-2.23_ossdetect_fix_git.patch
new file mode 100644
index 000000000000..484dd76f011c
--- /dev/null
+++ b/oss4_sys-libs_glibc-2.23_ossdetect_fix_git.patch
@@ -0,0 +1,18 @@
+commit ad097a606d8b6ba46e0bcd12b284ca355592ac44
+Author: hash <hashn0n@users.noreply.github.com>
+Date: Sun Sep 24 19:53:49 2017 +0300
+
+ Fix os_cmd/Linux/ossdetect/ossdetect.c compile problem with >=sys-libs/glibc-2.23, need to include sys/sysmacros.h
+
+diff --git a/os_cmd/Linux/ossdetect/ossdetect.c b/os_cmd/Linux/ossdetect/ossdetect.c
+index 86b86ba..1dce64a 100644
+--- a/os_cmd/Linux/ossdetect/ossdetect.c
++++ b/os_cmd/Linux/ossdetect/ossdetect.c
+@@ -12,6 +12,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/dir.h>
+
+ #define PCI_PASS 0