summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2017-11-06 16:12:53 -0500
committerSamuel Mesa2017-11-06 16:12:53 -0500
commitbd96275bdbe6e0920dd4fa966c7ce33089b5c75e (patch)
tree7787c609561620d8d6ae9d7ec9b8f478f54e464a
parentae0a9c9c85a0e4b5f1d31498b31b13320b16c670 (diff)
downloadaur-bd96275bdbe6e0920dd4fa966c7ce33089b5c75e.tar.gz
Update to version 2.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD86
-rw-r--r--fix-ossim-trac-2354.diff30
-rw-r--r--lib64bit_cmake_patch.patch11
4 files changed, 51 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ce0ae6d8ccd..2d027049dc4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu May 19 02:52:48 UTC 2016
pkgbase = ossim
pkgdesc = OSSIM is a powerful suite of geospatial libraries and applications used to process imagery, maps, terrain, and vector data.
- pkgver = 1.8.20.3
+ pkgver = 2.1.0
pkgrel = 1
url = http://www.ossim.org
install = ossim.install
@@ -15,7 +13,7 @@ pkgbase = ossim
depends = libgeotiff
depends = libjpeg
depends = libtiff
- depends = openscenegraph
+ depends = openthreads
depends = openjpeg
depends = doxygen
depends = hdf5-cpp-fortran
@@ -27,17 +25,14 @@ pkgbase = ossim
depends = liblas
depends = bzip2
depends = freetype2
+ depends = pdal
optdepends = java-environment-common
optdepends = openmpi
optdepends = gpstk-bin
- source = http://download.osgeo.org/ossim/source/latest/ossim-1.8.20-3.tar.gz
+ source = https://github.com/ossimlabs/ossim/archive/EgmontKey-2.1.0.tar.gz
source = ossim.sh
- source = lib64bit_cmake_patch.patch
- source = fix-ossim-trac-2354.diff
- md5sums = eb2265db0d4d9201e255b92317121cfd
- md5sums = bea65b5ac33115c85647840825c6b30b
- md5sums = 9531d170d973b85bcf8f0889d9415d99
- md5sums = 79e1e01bc9b8de9e0c0f481ccb19a8f7
+ md5sums = 3aadd69fefbe97a575010ffc7ba03f91
+ md5sums = cb85c216a099b10f057cddeeae4a57fb
pkgname = ossim
diff --git a/PKGBUILD b/PKGBUILD
index 1cc0f3c6791e..509832a6ffeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,22 @@
# Contributor: Christian Wygoda <accounts@wygoda.net>
pkgname=ossim
-pkgver=1.8.20.3
-_pkgver=1.8.20-3
+_pkgname=EgmontKey
+pkgver=2.1.0
pkgrel=1
pkgdesc="OSSIM is a powerful suite of geospatial libraries and applications used to process imagery, maps, terrain, and vector data."
url="http://www.ossim.org"
license=('LGPL')
arch=('i686' 'x86_64')
-depends=('freetype2' 'gdal' 'libgeotiff' 'libjpeg' 'libtiff' 'openscenegraph' 'openjpeg' 'doxygen' 'hdf5-cpp-fortran'
- 'minizip' 'expat' 'ffmpeg' 'qt4' 'podofo' 'liblas' 'bzip2' 'freetype2')
+depends=('freetype2' 'gdal' 'libgeotiff' 'libjpeg' 'libtiff' 'openthreads' 'openjpeg' 'doxygen'
+'hdf5-cpp-fortran' 'minizip' 'expat' 'ffmpeg' 'qt4' 'podofo' 'liblas' 'bzip2' 'freetype2' 'pdal')
makedepends=('cmake')
optdepends=( 'java-environment-common' 'openmpi' 'gpstk-bin' )
-source=(http://download.osgeo.org/ossim/source/latest/${pkgname}-${_pkgver}.tar.gz
- ossim.sh
- lib64bit_cmake_patch.patch
- fix-ossim-trac-2354.diff)
+source=(https://github.com/ossimlabs/ossim/archive/${_pkgname}-${pkgver}.tar.gz
+ ossim.sh )
install=ossim.install
-md5sums=('eb2265db0d4d9201e255b92317121cfd'
- 'cb85c216a099b10f057cddeeae4a57fb'
- '9531d170d973b85bcf8f0889d9415d99'
- '79e1e01bc9b8de9e0c0f481ccb19a8f7')
-
-prepare() {
- cd ${srcdir}/${pkgname}-${_pkgver}
- patch -p0 < ../lib64bit_cmake_patch.patch
- patch -p0 < ../fix-ossim-trac-2354.diff
-}
+md5sums=('3aadd69fefbe97a575010ffc7ba03f91'
+ 'cb85c216a099b10f057cddeeae4a57fb')
build() {
cd $srcdir
@@ -41,54 +31,68 @@ build() {
mkdir $srcdir/build
cd $srcdir/build
- OSSIM_DEV_HOME="$srcdir/${pkgname}-${_pkgver}";
- buildir="$srcdir/${pkgname}-${_pkgver}";
+ OSSIM_DEV_HOME="$srcdir/${pkgname}-${_pkgname}-${pkgver}";
+ buildir="$srcdir/${pkgname}-${_pkgname}-${pkgver}";
cmake -G "Unix Makefiles" \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_OSSIM_MPI_SUPPORT=OFF \
- -DBUILD_OSSIM_TEST_APPS=OFF \
- -DSubversion_SVN_EXECUTABLE="" \
- -DCMAKE_MODULE_PATH=${buildir}/ossim_package_support/cmake/CMakeModules \
- -DFREETYPE_INCLUDE_DIR_ft2build=/usr/include/freetype2 \
- -DBUILD_WMS=OFF \
+ -DFREETYPE_INCLUDE_DIR_ft2build=/usr/include/freetype2 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DINSTALL_LIBRARY_DIR:PATH=/usr/lib \
- -DINSTALL_RUNTIME_DIR:PATH=/usr/bin/ossim-apps/ \
-DINSTALL_ARCHIVE_DIR:PATH=/usr/lib \
- ${buildir}/ossim \
-
- make -j4
+ -DBUILD_GDAL_PLUGIN=ON \
+ -DBUILD_MRSID_PLUGIN=OFF \
+ -DBUILD_OMS=ON \
+ -DBUILD_OSSIM_APPS=ON \
+ -DBUILD_OSSIM_CURL_APPS=OFF \
+ -DBUILD_OSSIM_FRAMEWORK=ON \
+ -DBUILD_OSSIM_FREETYPE_SUPPORT=ON \
+ -DBUILD_OSSIM_GUI=ON \
+ -DBUILD_OSSIM_PLANET=ON \
+ -DBUILD_OSSIM_VIDEO=ON \
+ -DBUILD_OSSIM_HDF5_SUPPORT=ON \
+ -DBUILD_KAKADU_PLUGIN=OFF \
+ -DBUILD_OSSIM_ID_SUPPORT=ON \
+ -DBUILD_OSSIM_MPI_SUPPORT=OFF \
+ -DBUILD_OSSIM_TEST=ON \
+ -DBUILD_OSSIM_WMS=ON \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_PDAL_PLUGIN=ON \
+ $srcdir/${pkgname}-${_pkgname}-${pkgver} \
+
+ make
}
package() {
cd $srcdir/build
- buildir="$srcdir/${pkgname}-${_pkgver}";
+ buildir="$srcdir/${pkgname}-${_pkgname}-${pkgver}";
make DESTDIR=${pkgdir} install || return 1
sed -i -e 's|epsg_database_file1: $(OSSIM_DATA)/ossim/share/ossim/projection/ossim_epsg_projections-v7_4.csv|epsg_database_file1: $(OSSIM_DATA)/projection/ossim_epsg_projections-v7_4.csv|g' \
- ${buildir}/ossim/etc/templates/ossim_preferences_template
+ ${buildir}/share/ossim/templates/ossim_preferences_template
+
sed -i -e 's|epsg_database_file2: $(OSSIM_DATA)/ossim/share/ossim/projection/ossim_harn_state_plane_epsg.csv|epsg_database_file2: $(OSSIM_DATA)/projection/ossim_harn_state_plane_epsg.csv|g' \
- ${buildir}/ossim/etc/templates/ossim_preferences_template
+ ${buildir}/share/ossim/templates/ossim_preferences_template
+
sed -i -e 's|epsg_database_file3: $(OSSIM_DATA)/ossim/share/ossim/projection/ossim_state_plane_spcs.csv|epsg_database_file3: $(OSSIM_DATA)/projection/ossim_state_plane_spcs.csv|g' \
- ${buildir}/ossim/etc/templates/ossim_preferences_template
+ ${buildir}/share/ossim/templates/ossim_preferences_template
+
sed -i -e 's|epsg_database_file4: $(OSSIM_DATA)/ossim/share/ossim/projection/ossim_harn_state_plane_esri.csv|epsg_database_file4: $(OSSIM_DATA)/projection/ossim_harn_state_plane_esri.csv|g' \
- ${buildir}/ossim/etc/templates/ossim_preferences_template
+ ${buildir}/share/ossim/templates/ossim_preferences_template
sed -i -e 's|wkt_database_file: $(OSSIM_DATA)/ossim/share/ossim/projection/ossim_wkt_pcs.csv|wkt_database_file: $(OSSIM_DATA)/projection/ossim_wkt_pcs.csv|g' \
- ${buildir}/ossim/etc/templates/ossim_preferences_template
+ ${buildir}/share/ossim/templates/ossim_preferences_template
sed -i -e 's|geoid_ngs_directory: $(OSSIM_DATA)/ear1/geoid/geoid99|geoid_ngs_directory: $(OSSIM_DATA)/geoids/geoid99|g' \
- ${buildir}/ossim/etc/templates/ossim_preferences_template
+ ${buildir}/share/ossim/templates/ossim_preferences_template
sed -i -e 's|geoid_egm_96_grid: $(OSSIM_DATA)/ele1/geoid/geoid96/egm96.grd|geoid_egm_96_grid: $(OSSIM_DATA)/geoids/geoid1996/egm96.grd|g' \
- ${buildir}/ossim/etc/templates/ossim_preferences_template
-
+ ${buildir}/share/ossim/templates/ossim_preferences_template
# Install the templates file
- cp -r ${buildir}/ossim/etc/templates ${pkgdir}/usr/share/ossim/
+ cp -r ${buildir}/share/ossim/templates ${pkgdir}/usr/share/ossim/
# Install the configuration file
mkdir ${pkgdir}/etc
@@ -96,7 +100,7 @@ package() {
# Install profile.d file
install -D ${srcdir}/ossim.sh \
- ${pkgdir}/etc/profile.d/ossim.sh
+ ${pkgdir}/etc/profile.d/ossim.sh
}
diff --git a/fix-ossim-trac-2354.diff b/fix-ossim-trac-2354.diff
deleted file mode 100644
index 2738f998e4d7..000000000000
--- a/fix-ossim-trac-2354.diff
+++ /dev/null
@@ -1,30 +0,0 @@
---- ossim/src/ossim/elevation/ossimElevManager.cpp 2015-12-14 14:17:27.000000000 +0000
-+++ ossim/src/ossim/elevation/ossimElevManager.cpp.new 2016-03-29 14:44:34.310407167 +0000
-@@ -635,6 +635,11 @@
- return spacing;
- }
-
-+inline std::ostream& operator<<(std::ostream& out, std::ostream& obj)
-+{
-+ return obj;
-+}
-+
- std::ostream& ossimElevManager::print(ostream& out) const
- {
- out << "\nossimElevManager @ "<< (ossim_uint64) this
-diff -ur ossim-1.8.20-3.ossim.orig/src/ossim/elevation/ossimElevSource.cpp ossim-1.8.20-3.ossim.gcc6/src/ossim/elevation/ossimElevSource.cpp
---- ossim/src/ossim/elevation/ossimElevSource.cpp 2015-01-29 22:33:13.000000000 +0000
-+++ ossim/src/ossim/elevation/ossimElevSource.cpp.new 2016-03-29 14:44:34.310407167 +0000
-@@ -262,6 +262,11 @@
- theComputeStatsFlag = flag;
- }
-
-+inline std::ostream& operator<<(std::ostream& out, std::ostream& obj)
-+{
-+ return obj;
-+}
-+
- std::ostream& ossimElevSource::print(std::ostream& out) const
- {
- out << "\nossimElevSource @ "<< (ossim_uint64) this
-
diff --git a/lib64bit_cmake_patch.patch b/lib64bit_cmake_patch.patch
deleted file mode 100644
index d492ae840b45..000000000000
--- a/lib64bit_cmake_patch.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ossim_package_support/cmake/CMakeLists.txt 2015-09-03 08:13:44.000000000 -0500
-+++ ossim_package_support/cmake/CMakeLists.txt.cp 2016-05-18 15:21:17.389231844 -0500
-@@ -267,7 +267,7 @@
- ${${PROJECT_NAME}_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc
- @ONLY
- )
-- INSTALL(FILES ${${PROJECT_NAME}_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc DESTINATION lib${LIBSUFFIX}/pkgconfig COMPONENT ossim)
-+ INSTALL(FILES ${${PROJECT_NAME}_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc DESTINATION lib/pkgconfig COMPONENT ossim)
- ENDFOREACH(PKGCONFIG_FILE)
-
-