summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2018-12-16 00:16:30 +0100
committermorguldir2018-12-16 00:16:30 +0100
commit78790c6ee51fc070a1e63fb413eac0ae7585ebfd (patch)
tree14a717e923b8e1e280d682fb8840ab4c16667ff8
parent1e9bf64c9f51e2aa978325d59ae161fcab4e35ac (diff)
downloadaur-78790c6ee51fc070a1e63fb413eac0ae7585ebfd.tar.gz
Add a variable for dotnet version, bump it to 2.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63a8e7b57af3..e81c3e063f3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = osu-lazer
pkgdesc = The new open source version of osu!, the free-to-win rhythm game
pkgver = 2018.1214.0
- pkgrel = 1
+ pkgrel = 2
url = https://osu.ppy.sh/
arch = x86_64
license = MIT
license = custom:CC-BY-NC 4.0
makedepends = git
- makedepends = dotnet-sdk
+ makedepends = dotnet-sdk>=2.2.0
depends = ffmpeg
depends = libgl
depends = sdl2
- depends = dotnet-runtime
depends = shared-mime-info
+ depends = dotnet-runtime>=2.2.0
provides = osu-lazer
conflicts = osu-lazer-git
source = osu-2018.1214.0::git://github.com/ppy/osu.git#tag=2018.1214.0
diff --git a/PKGBUILD b/PKGBUILD
index d27ee7996d1f..c3b98f27fb44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,18 @@
pkgname=osu-lazer
pkgver=2018.1214.0
-pkgrel=1
+pkgrel=2
+
+dotnet_version=2.2
+
pkgdesc="The new open source version of osu!, the free-to-win rhythm game"
arch=('x86_64')
license=('MIT' 'custom:CC-BY-NC 4.0')
url='https://osu.ppy.sh/'
-depends=(ffmpeg libgl sdl2 dotnet-runtime shared-mime-info)
-makedepends=(git dotnet-sdk)
+
+depends=(ffmpeg libgl sdl2 shared-mime-info "dotnet-runtime>=$dotnet_version.0")
+makedepends=(git "dotnet-sdk>=$dotnet_version.0")
+
provides=(osu-lazer)
conflicts=(osu-lazer-git)
@@ -45,12 +50,12 @@ build()
{
cd "osu-$pkgver"
- dotnet publish osu.Desktop \
- --framework netcoreapp2.1 \
- --configuration Release \
- --runtime linux-x64 \
- --self-contained false \
- --output ./bin/Release/netcoreapp2.1/linux-x64
+ dotnet publish osu.Desktop \
+ --framework netcoreapp$dotnet_version \
+ --configuration Release \
+ --runtime linux-x64 \
+ --self-contained false \
+ --output ./bin/Release/netcoreapp$dotnet_version/linux-x64
}
package()
@@ -73,7 +78,7 @@ package()
install -m644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
# Compiled binaries
- cd "$srcdir/osu-$pkgver/osu.Desktop/bin/Release/netcoreapp2.1/linux-x64"
+ cd "$srcdir/osu-$pkgver/osu.Desktop/bin/Release/netcoreapp$dotnet_version/linux-x64"
mkdir -p "$pkgdir/usr/lib/$pkgname"
for binary in *.so *.dll *.json *.pdb; do
install -m755 "$binary" "$pkgdir/usr/lib/$pkgname/$binary"