summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2018-12-28 00:47:56 +0100
committermorguldir2018-12-28 00:48:37 +0100
commitfbe4544c2bea1916ae747831f85fcc267d152379 (patch)
tree6e9783394084a113e09d4af9d197b0e5dd02bc20
parent55f2f6500ce94b130522041afe446dbc188ca3ee (diff)
downloadaur-fbe4544c2bea1916ae747831f85fcc267d152379.tar.gz
Bump version to 2018.1227.1, add version number to the game
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2e7be152598..9ac817d09536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osu-lazer
pkgdesc = The new open source version of osu!, the free-to-win rhythm game
- pkgver = 2018.1219.0
+ pkgver = 2018.1227.1
pkgrel = 1
url = https://osu.ppy.sh/
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = osu-lazer
depends = dotnet-runtime>=2.2.0
provides = osu-lazer
conflicts = osu-lazer-git
- source = osu-2018.1219.0::git+https://github.com/ppy/osu.git#tag=2018.1219.0
+ source = osu-2018.1227.1::git+https://github.com/ppy/osu.git#tag=2018.1227.1
source = git+https://github.com/ppy/osu-resources.git
source = osu-launcher
source = osu-lazer.desktop
diff --git a/PKGBUILD b/PKGBUILD
index b718b4878191..c5ba20ac0c1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: "donaldtrump" [AUR]
pkgname=osu-lazer
-pkgver=2018.1219.0
+pkgver=2018.1227.1
pkgrel=1
dotnet_version=2.2
@@ -50,12 +50,13 @@ build()
{
cd "osu-$pkgver"
- dotnet publish osu.Desktop \
- --framework netcoreapp$dotnet_version \
- --configuration Release \
- --runtime linux-x64 \
- --self-contained false \
- --output ./bin/Release/netcoreapp$dotnet_version/linux-x64
+ dotnet publish osu.Desktop \
+ --framework netcoreapp$dotnet_version \
+ --configuration Release \
+ --runtime linux-x64 \
+ --self-contained false \
+ /property:Version=$pkgver \
+ --output ./bin/Release/netcoreapp$dotnet_version/linux-x64
}
package()