summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntti2022-12-10 18:16:12 +0200
committerAntti2022-12-10 18:16:12 +0200
commit0d98f63b1a95616a73d9d5e1101dfb66df172580 (patch)
tree3b4f279bbebb2a01553cd183a6ca4b4eb94674fc
parente3a800b39b03e2a6bb92b1f80a23b4c380544a3a (diff)
downloadaur-0d98f63b1a95616a73d9d5e1101dfb66df172580.tar.gz
Handle osu! URIs (osu!direct), bump pkgrel
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--osu-lazer-uri-handler.desktop9
-rw-r--r--osu-lazer.desktop2
4 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 974ace895fa4..3ead87815f6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = osu-lazer-bin
pkgdesc = The future of osu! and the beginning of an open era! Commonly known by the codename osu!lazer. Pew pew.
pkgver = 2022.1208.0
- pkgrel = 1
+ pkgrel = 2
url = https://osu.ppy.sh
arch = x86_64
license = MIT
@@ -18,11 +18,13 @@ pkgbase = osu-lazer-bin
source = https://raw.githubusercontent.com/ppy/osu/master/assets/lazer.png
source = https://raw.githubusercontent.com/ppy/osu-resources/master/LICENCE.md
source = osu-lazer.desktop
+ source = osu-lazer-uri-handler.desktop
source = osu-lazer
sha256sums = e3b17d419948b866337bef4dd4d4d02c5040880408a608a22d6ce18000b416ce
sha256sums = 36f73cfe0a84cd65a8bb54fcde5a01c419b134bee4a88cc92eb4f33236343a10
sha256sums = 30b914824784b6ba6b30a44b22bea4f3c6fbc10f3f0e74fde5ca76a92ef57244
- sha256sums = 43aba829341aa5542d7cedf9e95215d553a7db73a65f169f0de5a25aac75b801
+ sha256sums = e08a76a780960fffbd63fed26df21f0e7846d9bc8b366bfdbb54b07bf543113e
+ sha256sums = 44e9e6a85c43086644f427b62d6d8b265c0e2ac1b5091d8ff0c626c58a91836d
sha256sums = baeea5b234e65707a4e6a563eacac89063bf20047d64125cd1f26c3c52aae957
pkgname = osu-lazer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2b67220facf4..d7baa80ae3ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
# Contributor: Tyler Nelson <neo@cybercat.cc>
# Contributor: Tuhana GAYRETLÄ° <tuhana at tuta dot io>
# Contributor: Quenten Schoonderwoerd <ellie at nicecock dot eu>
+# Contributor: Antti <antti@antti.codes>
pkgname=osu-lazer-bin
_pkgname=${pkgname%-bin}
pkgver=2022.1208.0
-pkgrel=1
+pkgrel=2
pkgdesc="The future of osu! and the beginning of an open era! Commonly known by the codename osu!lazer. Pew pew."
arch=(x86_64)
url="https://osu.ppy.sh"
@@ -25,13 +26,15 @@ source=(
"https://raw.githubusercontent.com/ppy/osu/master/assets/lazer.png"
"https://raw.githubusercontent.com/ppy/osu-resources/master/LICENCE.md"
"osu-lazer.desktop"
+ "osu-lazer-uri-handler.desktop"
"osu-lazer"
)
noextract=("osu.AppImage")
sha256sums=('e3b17d419948b866337bef4dd4d4d02c5040880408a608a22d6ce18000b416ce'
'36f73cfe0a84cd65a8bb54fcde5a01c419b134bee4a88cc92eb4f33236343a10'
'30b914824784b6ba6b30a44b22bea4f3c6fbc10f3f0e74fde5ca76a92ef57244'
- '43aba829341aa5542d7cedf9e95215d553a7db73a65f169f0de5a25aac75b801'
+ 'e08a76a780960fffbd63fed26df21f0e7846d9bc8b366bfdbb54b07bf543113e'
+ '44e9e6a85c43086644f427b62d6d8b265c0e2ac1b5091d8ff0c626c58a91836d'
'baeea5b234e65707a4e6a563eacac89063bf20047d64125cd1f26c3c52aae957')
package() {
cd "$srcdir"
@@ -43,5 +46,6 @@ package() {
# Install pixmap, desktop and license file
install -Dm644 lazer.png "$pkgdir/usr/share/pixmaps/osu-lazer.png"
install -Dm644 -t "$pkgdir/usr/share/applications" osu-lazer.desktop
+ install -Dm644 -t "$pkgdir/usr/share/applications" osu-lazer-uri-handler.desktop
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENCE.md
}
diff --git a/osu-lazer-uri-handler.desktop b/osu-lazer-uri-handler.desktop
new file mode 100644
index 000000000000..8786426f5cae
--- /dev/null
+++ b/osu-lazer-uri-handler.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+NoDisplay=true
+Name=osu!lazer - uri handler
+MimeType=x-scheme-handler/osu;
+Icon=/usr/share/pixmaps/osu-lazer.png
+Comment=Open source free-to-win rhythm game
+Exec=/usr/bin/osu-lazer %u
+Categories=Game;
diff --git a/osu-lazer.desktop b/osu-lazer.desktop
index c9063b53d7bb..7e43dd1c585a 100644
--- a/osu-lazer.desktop
+++ b/osu-lazer.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Type=Application
Name=osu!lazer
-MimeType=application/x-osu-skin-archive;application/x-osu-replay;application/x-osu-beatmap-archive;x-scheme-handler/osu;
+MimeType=application/x-osu-skin-archive;application/x-osu-replay;application/x-osu-beatmap-archive;
Icon=/usr/share/pixmaps/osu-lazer.png
Comment=Open source free-to-win rhythm game
Exec=/usr/bin/osu-lazer